Bug 104370 - aic7xxx driver fails while configuring Winchester SCSI RAID box configuring Winchester RAID box
aic7xxx driver fails while configuring Winchester SCSI RAID box configuring ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Tom Coughlan
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-13 13:36 EDT by Tom Coughlan
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:34:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console log. (39.63 KB, text/plain)
2003-09-13 13:44 EDT, Tom Coughlan
no flags Details

  None (edit)
Description Tom Coughlan 2003-09-13 13:36:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
The aic7xxx driver fails while configuring the SCSI RAID box from Winchester
Systems. The driver seems to configure the adapter fine, but when it is probing
the SCSI LUNs the driver goes into an infinite loop spewing firmware dump
information.  See attachment.

This does not happen with the aic7xxx_old driver.  It also does not happen with
the taroon-a4 kernel, which had the older version of the aic7xxx driver. 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with Winsys raid box attached
2.
3.
    

Additional info:
Comment 1 Tom Coughlan 2003-09-13 13:43:14 EDT
Fails: 6.2.36
Works: 6.2.8, and aic7xxx_old
Comment 2 Tom Coughlan 2003-09-13 13:44:34 EDT
Created attachment 94476 [details]
Console log.
Comment 3 Doug Ledford 2003-10-02 02:49:04 EDT
This looks like a bug in the box firmware to me.  It reports scsi level 4 but
doesn't properly support high lun numbers.  I'm not positive that the extended
lun support is optional in scsi level 4.  Adding Justin to the cc list so he can
comment.
Comment 4 Tom Coughlan 2003-10-02 08:02:37 EDT
Justin did comment on this in mail to me. I thought I put this in the bugzilla,
but I guess not.  Sorry.  

I said:
> The rev 6.2.36 driver fails to configure the Winchester RAID box.  The
> rev 6.2.8 driver, and aic7xxx_old work.

Justin's reply:

Have you limted the number of LUNs exported by either the 6.2.8 driver
or the aic7xxx_old driver to something <= 32?  It looks like this particular
device cannot handle probing of luns > 32 - it ignores the high bit and
doesn't return it during reselection causing the driver to abort the command.
Perhaps there was a quirk entry for this device that prevented the high
scan?  Anyway, any device claiming SPC2 compliance (ANSI Rev 04) should
allow the high scan, so this guy looks broken.

------

I am working with Winchester to get this fixed.
Comment 5 RHEL Product and Program Management 2007-10-19 15:34:36 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.