Bug 104378 - Diacritical marks not displayed and other problems with en_US.UTF-8.
Summary: Diacritical marks not displayed and other problems with en_US.UTF-8.
Status: CLOSED DUPLICATE of bug 75811
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kbd   
(Show other bugs)
Version: 9
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-14 05:07 UTC by Z
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Z 2003-09-14 05:07:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030626

Description of problem:
Diacritical marks and other problems with en_US.UTF-8.

When using UTF-8 and KEYTABLE="us-acentos", the output of "dumpkeys" does not
show the accented charachters. Entering the c-cedilla charachter using "'"
deadkey and "c" yelds a "Ä" non-existing charachter instead of "ç".

The same problem happens even with en_US on some applications (gedit, mozilla),
but not in others (openoffice).
In summary: a mess.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.select LANG="en_US.UTF-8"
2.run dumpkeys on the console.

    

Actual Results:  3. whatch the "?" on the screen.

Expected Results:  The correct charachters should have beed displayed. It will
work with LANG="en_US"

Additional info:

As far as I know the Ä; is not part of any latin language. The c-cedilla is
essential for working in portuguese, so this bug is a showstopper.

Comment 1 Eido Inoue 2003-09-15 21:42:53 UTC

*** This bug has been marked as a duplicate of 75811 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:58:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.