Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1043933 - "Monitor" page displays "Failed" for all packages in a build if any package fails
Summary: "Monitor" page displays "Failed" for all packages in a build if any package f...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Copr
Classification: Community
Component: frontend
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Adam Samalik
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-17 13:08 UTC by Stephen Gallagher
Modified: 2014-04-30 07:11 UTC (History)
2 users (show)

Fixed In Version: copr-frontend-1.31-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-30 07:11:14 UTC


Attachments (Terms of Use)

Description Stephen Gallagher 2013-12-17 13:08:11 UTC
Description of problem:
When running a build with multiple packages in it, if at the end of the rebuild loops even one package failed to build, all of the packages will be displayed as "Failed". It then becomes necessary to examine all of the output logs to figure out which one(s) actually failed.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Add at least two packages to a COPR build, one known to build and one that will fail.
2. Run the build.
3. Examine the Monitor page afterwards.

Actual results:
Both 'goodpackage' and 'badpackage' are listed as "Failed".

Expected results:
The ones that succeeded should be displayed as such.

Additional info:
See build ID 390 (from the sgallagh/sssd-upstream-stable COPR) for an example of this.

Comment 1 Miroslav Suchý 2013-12-17 13:51:44 UTC
Yes, this known bug.
If you submit several src.rpm at once and that build failed, builder report is failed (because mockchain do). There is no way for frontend to distinguish if only one package fail and some succeed.

I understand that from user POV it does not matter and therefore I leave this bug open. But do not expect it resolved in near future.

Workaround is to submit one src.rpm for each build.

Comment 2 Ryan Lerch 2013-12-17 15:55:10 UTC
Isn't there a file in each package that specifies if a build failed or not? 

in this example, there is a file "success"

http://copr-be.cloud.fedoraproject.org/results/ryanlerch/gimp-goat-invasion/fedora-rawhide-i386/gegl-0.3.0-20131213git3a233c8.fc20/

if a build fails, there is a file "fail"

Comment 3 Miroslav Suchý 2014-04-02 15:19:57 UTC
Since:
 * 4e04de0 building pkgs separately

all rpms should be build separately. Each one in one task. Which should solve this problem (and several others).

Comment 4 Miroslav Suchý 2014-04-30 07:11:14 UTC
Code deployed to copr.fedoraproject.org


Note You need to log in before you can comment on or make changes to this bug.