Bug 1043946 - BVT: Provisioning of RHSS2.1 through use of kick start file with latest GlusterFS rpms fails
Summary: BVT: Provisioning of RHSS2.1 through use of kick start file with latest Glust...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: 2.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: RHGS 2.1.2
Assignee: Niels de Vos
QA Contact: Lalatendu Mohanty
URL:
Whiteboard:
Depends On: 1022822
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-17 13:39 UTC by Lalatendu Mohanty
Modified: 2015-05-15 18:20 UTC (History)
9 users (show)

Fixed In Version: glusterfs-3.4.0.51rhs-1.el6rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 08:09:16 UTC
Target Upstream Version:


Attachments (Terms of Use)
Error from console (14.36 KB, image/png)
2013-12-17 13:39 UTC, Lalatendu Mohanty
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 0 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 12:20:30 UTC

Description Lalatendu Mohanty 2013-12-17 13:39:59 UTC
Created attachment 837692 [details]
Error from console

Description of problem:

Provisioning of RHSS2.1 through use of kickstart file with latest GlusterFS rpms i.e. glusterfs-libs-3.4.0.50rhs-1.el6rhs.x86_64.rpm fails with below error in console.

"Error Installing package
A fatal error occurred when installing the glusterfs-libs package. This could indicate errors when reading the installation media. Installation can't continue"
 
The issue can be seen when ISO "RHSS-2.1-20131215.n.0-RHS-x86_64-DVD1" or RHS2.1U1 GA ISO used as source tree 

This came in to light when provisioning of the RHSS machines failed for BVT runs. Beaker provisioning failed for the latest RPMs with below error.

Installing glusterfs-libs-3.4.0.50rhs-1387276796.el6.x86_64
error: %pretrans(glusterfs-libs-3.4.0.50rhs-1387276796.el6.x86_64) scriptlet failed, exit status 127

This issue is not seen for "yum install" or "yum update" for mentioned gluster RPMs. But I think we will hit this issue when we will create an ISO with the latest RPMs.

Version-Release number of selected component (if applicable):
glusterfs-libs-3.4.0.50rhs-1.el6rhs.x86_64.rpm

How reproducible:
Always

Steps to Reproduce:
1. Create a kickstart file for RHSS
2. In the kickstart file use the repo which has the latest RPMs
2. Use RHSS-2.1-20131215.n.0-RHS-x86_64-DVD1 as source tree and try to install the OS

Actual results:


Expected results:


Additional info:

Comment 2 Harshavardhana 2013-12-17 21:51:51 UTC
This is interesting issue - can we gather more information here? the 'pretrans' part doesn't seem to do much unless the 'pidof' part thinks that 'glusterfsd' process is running. 

%pretrans libs

 pidof -c -o %PPID -x glusterfsd &>/dev/null ---------> Here! 

 if [ $? -eq 0 ]; then -------> Here! 
   pushd . > /dev/null 2>&1
   for volume in /var/lib/glusterd/vols/*; do cd $volume;
       vol_type=`grep '^type=' info | awk -F'=' '{print $2}'`
       volume_started=`grep '^status=' info | awk -F'=' '{print $2}'`
       if [[ $vol_type -eq 0 && $volume_started -eq 1 ]] ; then
          echo "ERROR: In-service rolling upgrade requires pure distribute volume(s), should be stopped"
          echo "ERROR: Please stop distribute volume(s) before proceeding... exiting!"
          exit 1;
       fi
   done

   popd > /dev/null 2>&1
   echo "WARNING: Updating glusterfs requires its processes to be killed. This action does NOT incur downtime."
   echo "WARNING: Ensure to wait for the upgraded server to finish healing before proceeding."
   echo "WARNING: Refer install/upgrade guide for more details"
   echo "Please run # service glusterd stop; pkill glusterfs; pkill glusterfsd; pkill gsyncd.py;"
 fi

Also the %pretrans by itself could be causing this issue - Niels i think this is what i was worried?

Comment 3 Harshavardhana 2013-12-18 01:32:37 UTC
Okay so the problem here is %pretrans

The issue is this - https://fedoraproject.org/wiki/Packaging:Guidelines?rd=Packaging/Guidelines#The_.25pretrans_scriptlet

%pretrans is invoked very early before the dependencies are met, so a shell cannot be coded into "%pretrans" block - we should instead use "lua" 

http://www.rpm.org/wiki/PackagerDocs/RpmLua - i will sending out another patch.

Comment 4 Harshavardhana 2013-12-18 01:33:58 UTC
Either that we write in "lua" or we completely avoid it by using "%pre" which basically no such restrictions. Its upto you guys to decide, i can go with either way here "lua" a new patch or removing %pretrans as we did before in RHS 2.1 Update 1

Comment 5 Bala.FA 2013-12-18 02:11:22 UTC
Patch is under review at https://code.engineering.redhat.com/gerrit/#/c/17611/

Comment 6 Gowrishankar Rajaiyan 2013-12-18 08:57:31 UTC
Please set the priority.

Comment 7 Niels de Vos 2013-12-18 15:55:52 UTC
Patch that is supposed to fix this is part of bug 1022822.

Comment 8 Gowrishankar Rajaiyan 2013-12-19 06:24:54 UTC
Please set priority.

Comment 9 Lalatendu Mohanty 2013-12-19 15:13:13 UTC
Not seeing the issue any more with glusterfs-3.4.0.51rhs-1.el6rhs. Marking it verified

Comment 11 errata-xmlrpc 2014-02-25 08:09:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html


Note You need to log in before you can comment on or make changes to this bug.