Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1043965 - rsync won't talk to rsync-3.1.0-2
Summary: rsync won't talk to rsync-3.1.0-2
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsync
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Michal Luscon
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1102637
TreeView+ depends on / blocked
 
Reported: 2013-12-17 14:18 UTC by Need Real Name
Modified: 2014-08-22 11:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-22 11:35:44 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Samba Project 10372 0 None None None Never

Description Need Real Name 2013-12-17 14:18:19 UTC
I have a client copying server data for backup using rsync over ssh

rsync --numeric-ids --partial -az --rsh=ssh --del --compress root@1.2.3.4:/home_server_path/ /path_to_local_backup/

the problem:
if server rsync is compiled from rsync-3.0.9-12.fc19.src.rpm
then any client rsync version works fine (rsync-3.0.9, rsync-3.1.0-2 , rsync-3.1pre1)

If server rsync is compiled from rsync-3.1.0-2.fc21.src.rpm
then no client rsync works to completion.
Typically transfer starts, go for 1-2 hours, then fails with error message like this:

--------- client 3.1.0pre1 errors----------
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(557) [receiver=3.1.0pre1]
rsync: connection unexpectedly closed (2454943 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [generator=3.1.0pre1]
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(557) [receiver=3.1.0pre1]
rsync: [generator] write error: Broken pipe (32)
rsync error: error in socket IO (code 10) at io.c(837) [generator=3.1.0pre1]
------------ client 3.0.9 errors ----------
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(548) [receiver=3.0.9]
rsync: connection unexpectedly closed (1575 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(605) [generator=3.0.9]
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(548) [receiver=3.0.9]
rsync: connection unexpectedly closed (1403 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(605) [generator=3.0.9]

--------------------

Comment 1 Need Real Name 2013-12-17 18:09:32 UTC
I posted this report to original rsync bugzilla
https://bugzilla.samba.org/show_bug.cgi?id=10332

Comment 2 Orion Poplawski 2014-03-18 16:22:36 UTC
I think this is probably caused by rsync-3.1.0-0.1.pre1 and later using the system zlib instead of the bundled.  Linked to upstream report.  Seems to work the other way too (new rsync not talking to older rsync).

Comment 3 Need Real Name 2014-03-28 19:30:32 UTC
upgraded system zlib to 1.2.8, recompiled rsync-3.1.0-2.

 Got errors 
 inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(557) [receiver=3.1.0]
rsync: connection unexpectedly closed (2535208 bytes received so far) [generator]
rsync error: error in rsync protocol data stream (code 12) at io.c(226) [generator=3.1.0]
inflate returned -3 (0 bytes)
rsync error: error in rsync protocol data stream (code 12) at token.c(557) [receiver=3.1.0]
rsync: [generator] write error: Broken pipe (32)
rsync error: error in socket IO (code 10) at io.c(837) [generator=3.1.0]

reverted to back to 3.0.9

Comment 4 Michal Luscon 2014-03-31 11:26:49 UTC
Hi,

does this happen every time for every types of files? I am currently not able to reproduce it with F20 and Arch.

Comment 5 Orion Poplawski 2014-03-31 12:56:23 UTC
I've only seen it with specific sparse files (mysql DBs and qemu raw images).  I think a quick revert to building with rsync's zlib is in order until this can be figured out.

Comment 6 Michal Luscon 2014-04-01 19:34:40 UTC
I have transferred several gigabytes of qemu images and DBs files without a reproduction. Are you able to provide me an example of file or sequence causing this issue?

Comment 7 Michal Luscon 2014-04-17 08:39:18 UTC
Compilation with system provided zlib has been temporary reverted in rsync-3.1.0-3. You can find deeper explanation in upstream bugzilla https://bugzilla.samba.org/show_bug.cgi?id=10372 .

Comment 8 Michal Luscon 2014-08-22 11:35:44 UTC
With modified upstream we can close this one and keep open just #1102637.


Note You need to log in before you can comment on or make changes to this bug.