Bug 104401 - Installer (anaconda) fails when searching for previous Redhat Installations
Installer (anaconda) fails when searching for previous Redhat Installations
Status: CLOSED DUPLICATE of bug 102193
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
9
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-14 19:14 EDT by Henry Nissenbaum
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda Failure dump file (41.33 KB, text/plain)
2003-09-14 19:16 EDT, Henry Nissenbaum
no flags Details

  None (edit)
Description Henry Nissenbaum 2003-09-14 19:14:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.11 (X11; Linux i686; U;) Gecko/20030417

Description of problem:
Attempting to upgrade a Redhat 8.0 installation to 9.0.

Installation fails when anaconda searches for previous installations.  The same
failure occurs regardless of whether the GUI or Text interface is used and with
or without using 'boot: linux upgradeany'.

The file /etc/redhat-release has NOT been modified and contains:
    Red Hat Linux release 8.0 (Psyche)


Version-Release number of selected component (if applicable):
installing from shrike-i386-disc1.iso

How reproducible:
Always

Steps to Reproduce:
1. Place CD with image of shrike-i386-disc1.iso in boot drive and power up.
2. Proceed with installation in either graphical or text mode through language,
keyboard, and mouse selection.
3. Anaconda starts search for previous Red Hat installation and dies with an
error message.  A dump file was captured to a floppy and a copy of that file is
attached to this report.
    

Actual Results:  See above

Expected Results:  See above

Additional info:
Comment 1 Henry Nissenbaum 2003-09-14 19:16:24 EDT
Created attachment 94487 [details]
Anaconda Failure dump file
Comment 2 Michael Fulbright 2003-09-15 16:47:00 EDT
There are several read errors from your error dump - I would recommend using the
mediacheck to inspect your install media.
Comment 3 Henry Nissenbaum 2003-09-15 22:40:08 EDT
Passed the media check on the first attempt to install.
I will make another disc copy and try again.
Comment 4 Michael Fulbright 2003-09-17 12:10:30 EDT
I have seen discs passed the mediacheck and still have failures in the middle of
an install.  The mediacheck just catches the obviously bad CDs.
Comment 5 Henry Nissenbaum 2003-09-17 19:47:31 EDT
It doesn't look there's a problem with the media.  I have two CD drives in the
machine:
    /dev/scd0  which is a 'CyberDrv' CW088D CD-R/RW 
    /dev/hdc   which is a Toshiba DVD-ROM SD-M1712

I used the first drive to burn the CDs and then used that same drive for the
installation/upgrade which gave me the problem.  Note that mounting the CD had
no problems in addition to mdiacheck passing.

When I tried using the second drive (/dev/hdc) I had no problem with the
installation using the same media. and am now using 9.0

This is likely a real bug somewhere but since it is no longer an issue you may
want to close the bug.

Thanks ...
Comment 6 Michael Fulbright 2003-09-24 16:56:58 EDT
Try the attachment to bug 102193.

*** This bug has been marked as a duplicate of 102193 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:58:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.