Bug 1044076 - fedup 19->20 fails
Summary: fedup 19->20 fails
Keywords:
Status: CLOSED DUPLICATE of bug 1044086
Alias: None
Product: Fedora
Classification: Fedora
Component: fedup
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-17 18:27 UTC by Tommi Kyntola
Modified: 2013-12-18 17:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-18 17:10:20 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tommi Kyntola 2013-12-17 18:27:44 UTC
Description of problem:

fedup from 19 to 20 runs smoothly and then shortly after a reboot things go sour. All I see is a whole lot of complaints about binfmt_misc mount failing.
It drops to a rescue shell after which it reboots back to f19 where everything is thankfully still ok.

Version-Release number of selected component (if applicable):
fully updated f9

How reproducible:
every time, I tried four times

Steps to Reproduce:
1. fedup-cli --network 20
2. reboot
3. fails, reboot back to 19

Additional info:
Lenovo X1 carbon, encrypted /home, hundreds of lines like these clutter the logs:
Dec 17 20:02:09 musta mount[1009]: mount: unknown filesystem type 'binfmt_misc'
Dec 17 20:02:09 musta systemd[1]: proc-sys-fs-binfmt_misc.mount mount process exited, code=exited status=32
Dec 17 20:02:09 musta systemd[1]: Failed to mount Arbitrary Executable File Formats File System.

Here's what journalctl said:
proc-sys-fs-binfmt_misc.mount - Arbitrary Executable File Formats File System
   Loaded: loaded (/usr/lib/systemd/system/proc-sys-fs-binfmt_misc.mount; static)
   Active: failed (Result: exit-code) since Tue 2013-12-17 20:14:21 EET; 1min 17s ago
    Where: /proc/sys/fs/binfmt_misc
     What: binfmt_misc
     Docs: https://www.kernel.org/doc/Documentation/binfmt_misc.txt
           http://www.freedesktop.org/wiki/Software/systemd/APIFileSystems
  Process: 1185 ExecMount=/bin/mount binfmt_misc /proc/sys/fs/binfmt_misc -t binfmt_misc (code=exited, status=32)

Dec 17 20:14:21 musta systemd[1]: Failed to mount Arbitrary Executable File Formats File System.
Dec 17 20:14:21 musta systemd[1]: Unit proc-sys-fs-binfmt_misc.mount entered failed state.
Dec 17 20:14:21 musta systemd[1]: Mounting Arbitrary Executable File Formats File System...
Dec 17 20:14:21 musta systemd[1]: proc-sys-fs-binfmt_misc.mount mount process exited, code=exited status=32
Dec 17 20:14:21 musta systemd[1]: Failed to mount Arbitrary Executable File Formats File System.
Dec 17 20:14:21 musta systemd[1]: Unit proc-sys-fs-binfmt_misc.mount entered failed state.

Comment 1 Matthew Booth 2013-12-18 12:20:20 UTC
Pretty sure these are red herrings. They appear to be failing because the initrd doesn't contain the relevant kernel module. However, apart from creating untidy errors in the logs, they don't seem to have any negative impact.

I had exactly the same, and I forcefully disabled proc-sys-fs-binfmt_misc.mount. The result was that the boot still failed, but I could now see the real error messages without the binfmt_misc spam.

I suspect you're hitting bug 1044086.

Comment 2 Tommi Kyntola 2013-12-18 17:10:20 UTC
Indeed they are. I'll mark this a dupe.

*** This bug has been marked as a duplicate of bug 1044086 ***


Note You need to log in before you can comment on or make changes to this bug.