Bug 1044111 - [GSS 7.0][RFE] tuned should edit kernel command line
Summary: [GSS 7.0][RFE] tuned should edit kernel command line
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: tuned
Version: 7.0
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: qe-baseos-daemons
URL: http//
Whiteboard:
Depends On:
Blocks: 1113520 1064025 1110708 1130818 1132234 1135974 1191595
TreeView+ depends on / blocked
 
Reported: 2013-12-17 20:09 UTC by Karl Hastings
Modified: 2019-06-13 07:56 UTC (History)
6 users (show)

Fixed In Version: tuned-2.4.0-0.el7
Doc Type: Enhancement
Doc Text:
Feature: Tuned can now edit kernel (dracut) boot command line. Reason: See comment 3. Result: For full description of this feature see comment 8.
Clone Of:
: 1130818 1132234 1135974 (view as bug list)
Environment:
Last Closed: 2015-03-05 13:28:41 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0550 normal SHIPPED_LIVE tuned bug fix and enhancement update 2015-03-05 16:45:23 UTC

Description Karl Hastings 2013-12-17 20:09:27 UTC
Description of problem:
tuned should have the ability to add options to the kernel command line based on the defined profiles

Steps to Reproduce:
1. Given a tuned profile that requests a kernel command line parameter
  e.g. intel_idle.max_cstate=0

Expected results:
tuned should (using grubby or something similar) be able to edit the kernel command line to add/remove the specified kernel option.

Comment 2 Jaroslav Škarvada 2014-07-10 12:00:49 UTC
Currently tuned allows changing the settings in the run time without reboot and this RFE will break this useful feature.

Tuned now controls the max_cstate dynamically through the PM QOS interface which is very flexible. What will be the benefit to set it statically? In such case tuned will not be able to increase the max_cstate without reboot. This may also confuse users.

Please note with grub2, editing the kernel command line is a pain. You need to patch the grub.cfg and also simultaneously edit the grub2 templates because you need to cover the case when the user regenerates the config with the grub2-mkconfig command. AFAIK this is currently not done by grubby.

Is there any other use case than the intel_idle.max_cstate=0? Is it needed for custom profiles? In such case I could write such plugin, but I am against using this feature in the shipped profiles.

Comment 4 Karl Hastings 2014-07-10 23:14:56 UTC
Jaroslav,

As Jeremy has mentioned there are quite a few other parameters that would be nice if tuned could handle from a profile.

the intel_idel.max_cstate=0 was simply an example.

Comment 7 Jaroslav Škarvada 2014-09-29 14:38:11 UTC
Upstream commit adding this feature:
https://git.fedorahosted.org/cgit/tuned.git/commit/?id=5b8a2d2e8e77ca502ed70da6db86ffe9eaae5076

Comment 17 Jiri Herrmann 2014-12-12 15:31:22 UTC
If this Feature should be included in the 7.1 Release Notes, could you please change the Doc Type from Enhancement to "Release Note"?

Note that the Release Notes are intended to list the most prominent and customer-relevant new features rather than every single enhancement.

Cheers,
Jirka

Comment 18 Jaroslav Škarvada 2014-12-12 16:17:45 UTC
(In reply to Jiri Herrmann from comment #17)
I think it doesn't need release note.

Comment 21 errata-xmlrpc 2015-03-05 13:28:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0550.html


Note You need to log in before you can comment on or make changes to this bug.