Bug 1044233 - [ALL LANG]Anaconda->Timezone-> Not fully localized.
Summary: [ALL LANG]Anaconda->Timezone-> Not fully localized.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Vratislav Podzimek
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-17 23:40 UTC by Noriko Mizumoto
Modified: 2015-03-05 13:57 UTC (History)
13 users (show)

Fixed In Version: anaconda-19.31.100-1
Doc Type: Bug Fix
Doc Text:
Cause: Anaconda didn't respect chosen language (locale) when displaying date. Consequence: Fixed date format used for all languages. Fix: Anaconda respects chosen language (locale) when displaying date. Result: Different date formats for different languages.
Clone Of:
Environment:
Last Closed: 2015-03-05 13:57:12 UTC
Target Upstream Version:


Attachments (Terms of Use)
date format incorrect (462.17 KB, image/png)
2014-09-24 03:06 UTC, Noriko Mizumoto
no flags Details
date-format-correct-for-japanese.png (308.67 KB, image/png)
2014-10-20 06:22 UTC, Mike FABIAN
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0312 0 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2015-03-05 17:35:22 UTC

Description Noriko Mizumoto 2013-12-17 23:40:58 UTC
Description of problem:
While installing, there are strings appeared in English.


Version-Release number of selected component (if applicable):
This is the result from RHEL7 QA Event held on 2013-12-18
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.0-20131127.1/compose/Client/x86_64/os/
anaconda-19.31.36-1.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. HTTP install
2. Choose Japanese
3. Configure timezone

Actual results:
1) 'area' selection list in English (such as Asia, Europe, etc)
2) 'city' selection list in English (such as Tokyo, etc)
3) '-th' and 'year' missing from the date, it appears as '12月 17 2013'

Expected results:
1) 'area' selection list in Japanese (such as アジア,ヨーロッパ, etc)
2) 'city' selection list in Japanese (such as 東京, etc)
3) '-th' and 'year' missing from the date, it should appears as '12月 17日 2013年' or '2013年 12月 17日'. The latter is more proper way.

Additional info:

Comment 2 Yulia 2013-12-18 01:43:11 UTC
Steps 1-2 confirmed for Russian as well.

Comment 3 Eunju, Kim 2013-12-18 04:41:18 UTC
Steps 1-2 confirmed for Korean as well.

Comment 4 Francesco Valente 2013-12-18 05:03:29 UTC
Same problem for Italian.

Comment 5 Nilamdyuti 2013-12-18 11:11:40 UTC
Steps 1-2 confirmed for Assamese as well.

Comment 6 Angela Garcia 2013-12-19 00:26:39 UTC
Steps 1-2 confirmed for Spanish as well.

Comment 11 Noriko Mizumoto 2014-09-24 03:06:21 UTC
Created attachment 940653 [details]
date format incorrect

Hi
I tried to reproduce this bug with the image RHEL-7.0-20140409.0-Server-x86_64-dvd1.iso. 

1)'area' appears in Japanese as expected.
2)'city' appears in Japanese as expected.
3)'-th' and 'year' are still missing, please see attached screenshot (bottom right corner, the format is '9月 24 2014').

I've tried to issue 'date' command.
[root@localhost ~]# rpm -qa | grep tzdata
tzdata-java-2014b-1.el7.noarch
tzdata-2014b-1.el7.noarch
[root@localhost ~]# LANG=ja_JP.utf8
[root@localhost ~]# date
2014年  9月 24日 水曜日 13:01:34 EST

The order of year-month-date shown in anaconda and tzdata is different, one is '9月 24 2014' (month-date-year) while another '2014年 9月 24日' (year-month-date).

Comment 12 Mike FABIAN 2014-09-24 06:09:46 UTC
The translations for area and city probably come from langtable.

But not the date format, that is certainly not from langtable.

Comment 13 Noriko Mizumoto 2014-09-24 06:26:45 UTC
The component is changed to 'anaconda', as the date appears in comboboxes seems not using tzdata. 

3)'-th' and 'year' are still missing, please see attached screenshot (bottom right corner, the format is '9月 24 2014').

Comment 14 Mike FABIAN 2014-10-01 08:42:16 UTC
Back to Anaconda.

Noriko Mizumoto, comment#11> 1)'area' appears in Japanese as expected.
Noriko Mizumoto, comment#11> 2)'city' appears in Japanese as expected.

So the translations (which come from langtable) are there.

The localization of the time date format at the bottom right of
the time zone screen in Anaconda is not from langtable.

These are 3 comboboxes which are most likely hardcoded in that order
by Anaconda.

Comment 16 Mike FABIAN 2014-10-20 06:22:15 UTC
Created attachment 948407 [details]
date-format-correct-for-japanese.png

The comboboxes to set the date look very good for Japanese now.

Comment 17 Noriko Mizumoto 2014-10-20 11:56:36 UTC
(In reply to Mike FABIAN from comment #16)
> Created attachment 948407 [details]
> date-format-correct-for-japanese.png
> 
> The comboboxes to set the date look very good for Japanese now.

OH! I can see them beautifully perfect, thank you!

Comment 19 errata-xmlrpc 2015-03-05 13:57:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0312.html


Note You need to log in before you can comment on or make changes to this bug.