Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1044253 - Selected keyboard not working
Summary: Selected keyboard not working
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xkeyboard-config
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 01:52 UTC by Noriko Mizumoto
Modified: 2016-12-06 00:55 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 03:07:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
Xorg.0.log (18.19 KB, text/plain)
2014-01-06 04:01 UTC, Noriko Mizumoto
no flags Details
Xorg.9.log (18.60 KB, text/plain)
2014-01-06 04:02 UTC, Noriko Mizumoto
no flags Details

Description Noriko Mizumoto 2013-12-18 01:52:30 UTC
Description of problem:


Version-Release number of selected component (if applicable):
http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.0-20131127.1/compose/Client/x86_64/os/
kbd-1.15.5-7.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Fresh install
2. Set language > Japanese
3. Set keyboard -> English (US)

Actual results:
The keyboard layout is set to Japanese keyboard.

Expected results:
The keyboard layout is sest to English (US) keyboard.

Additional info:

Comment 2 Vitezslav Crhonek 2013-12-18 11:02:38 UTC
Does it happen in graphical mode (X server), or in the text console (ctrl+alt+Fx)?

What is output of 'cat /etc/vconsole.conf'?

Comment 3 Noriko Mizumoto 2013-12-19 01:18:58 UTC
It happens in graphical mode.

[nmizumoto@localhost ~]$ cat /etc/vconsole.conf 
KEYMAP="us"
FONT="latarcyrheb-sun16"

Comment 4 Vitezslav Crhonek 2013-12-19 08:40:55 UTC
Thanks, vconsole setting looks fine. If it happens in the graphical mode, then it is not problem of kbd. But I'm not sure in which component the bug is. It could be Anaconda, systemd-localed, xkeyboard-config...

What is output of "localectl"?

Comment 5 Noriko Mizumoto 2013-12-20 00:25:49 UTC
Hi here is the output

[nmizumoto@localhost Desktop]$ localectl
   System Locale: LANG=ja_JP.utf8
                  LC_NUMERIC=ja_JP.UTF-8
                  LC_TIME=ja_JP.UTF-8
                  LC_MONETARY=ja_JP.UTF-8
                  LC_PAPER=ja_JP.UTF-8
                  LC_MEASUREMENT=ja_JP.UTF-8
       VC Keymap: us
      X11 Layout: us,jp
     X11 Variant: ,

Comment 6 Vitezslav Crhonek 2014-01-02 10:10:00 UTC
(In reply to Noriko Mizumoto from comment #5)
> Hi here is the output
> 
> [nmizumoto@localhost Desktop]$ localectl
>    System Locale: LANG=ja_JP.utf8
>                   LC_NUMERIC=ja_JP.UTF-8
>                   LC_TIME=ja_JP.UTF-8
>                   LC_MONETARY=ja_JP.UTF-8
>                   LC_PAPER=ja_JP.UTF-8
>                   LC_MEASUREMENT=ja_JP.UTF-8
>        VC Keymap: us
>       X11 Layout: us,jp
>      X11 Variant: ,

Looks good.

Maybe the X11 layout is dual one and has to be switched somehow? Reassigning to xkeyboard-config.

Comment 7 Peter Hutterer 2014-01-06 01:31:27 UTC
please attach your xorg.log file. From the localctl output it looks like the X layout is configured to provide both us and jp, but given that us is the first group it should be the active one. I suspect gdm or GNOME is changing the group on login.

Comment 8 Noriko Mizumoto 2014-01-06 04:01:04 UTC
Created attachment 845895 [details]
Xorg.0.log

Here two log files attached, 0 and 9.

Comment 9 Noriko Mizumoto 2014-01-06 04:02:09 UTC
Created attachment 845896 [details]
Xorg.9.log

Comment 10 Peter Hutterer 2014-02-13 22:34:38 UTC
Ok, I need you to test something please. The issue could be with the xserver startup but it's most likely the desktop environment/GDM changing things.
Run the following commands to test a plain X session:

1. sudo yum install -y xterm 
2. sudo systemctl stop gdm.service
log in on the tty as your user
3. xinit

This starts up a plain X server with xterm as the only client. What language is set for your keyboard? jp or us?

exiting the xterm will drop you back to the tty, and you can systemctl start gdm.service to get back to gdm.

Comment 11 Peter Hutterer 2014-02-18 03:06:44 UTC
I just installed a fresh box, selecting Japanese during the install but selecting US as keyboard. On boot up, after login (no password), the initial setup tool offered japanese as default with US already in the list. 

xorg.log shows us, jp as layouts as does your file.

At the gdm login screen and once logged in, the language switcher shows en as default, with jp as selectable second.

At this point I'd like to know, in addition to Comment 10's request, what the exact steps were to reproduce this, and if this is still an issue with the most up-to-date version.

Comment 12 Lijun Li 2014-02-19 03:07:53 UTC
Fresh installed with latest build and cannot reproduced the issue.

Select English(US) keyboard works as expect in Comment 11.

Closing it.

Comment 13 Jens Petersen 2014-02-19 04:10:51 UTC
> 3. Set keyboard -> English (US)

This step is a bit unclear:

You mean you added a US layout in addition to the JP one
in the installer Keyboard screen?

Since I don't use JP keyboard either I usually
remove JP keyboard and add US keyboard there.

At least doing that I don't see any problem on RHEL-7.0-Client-20140214.0.
Let me try to do another install where I add US rather than replacing JP.

Comment 14 Jens Petersen 2014-02-19 04:39:34 UTC
(In reply to Jens Petersen from comment #13)
> Let me try to do another install where I add US rather than replacing JP.

In this case US will be added as a secondary keyboard layout
which is expected behaviour in this case I think.

Noriko, I guess what you want to do was either move US
layout above JP one in priority or like me just remove
the JP layout in the installer completely.


Note You need to log in before you can comment on or make changes to this bug.