Bug 104427 - [RFE] applet should run as nice 10 since it is informational only
[RFE] applet should run as nice 10 since it is informational only
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: rhn-applet (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 10:43 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-15 11:21:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-09-15 10:43:08 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030722
Galeon/1.3.8

Description of problem:
This background applet is only designed to occasionally poll the Red Hat server
to see if there are applicable updates to the system.  During this querying
process and comparison with the local machine, the applet can spike (CPU
resources) capturing CPU time from other processes.  Since it is not mission
critical that the applet run at the same priority level as other processes, this
"background" applet should run itself as nice 10 (or whatever deemed to be
appropriate).

Version-Release number of selected component (if applicable):
rhn-applet-2.0.10-5

How reproducible:
Always

Steps to Reproduce:
1. see description


Actual Results:  Runs at the same level of every other process.

Expected Results:  Runs if there is idle processor time available.

Additional info:
Comment 1 Daniel Veillard 2003-09-15 11:21:40 EDT
Makes sense, I implemented it, this should show up in version 2.0.11
once it reaches Rawhide,

  thanks,

Daniel

Note You need to log in before you can comment on or make changes to this bug.