Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1044360 - [redhat_access_plugin] Redhat access search via horizon should allow up to one search operation at a time
Summary: [redhat_access_plugin] Redhat access search via horizon should allow up to on...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: redhat-access-plugin-openstack
Version: 4.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Dan Varga
QA Contact: Ido Ovadia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 08:30 UTC by Rami Vaknin
Modified: 2019-09-10 14:08 UTC (History)
7 users (show)

Fixed In Version: redhat-access-plugin-openstack-5.0.0-0.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 15:41:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot1 (87.06 KB, image/png)
2013-12-18 08:30 UTC, Rami Vaknin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0855 0 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Dashboard 2014-07-08 19:33:24 UTC

Description Rami Vaknin 2013-12-18 08:30:36 UTC
Created attachment 838170 [details]
Screenshot1

[redhat_access_plugin] Redhat access search via horizon should allow up to one search operation at a time

Scenario
========
1. Log in to Horizon => "Red Hat" tab => "Search" sub-tab => sign in with rhn account credentials
2. Enter a search string in the search box and click on the "Search" button more than once before the results actually appear

- Just note that this can be happen without abuse intentions because the search might take time however the gui does not indicate that the search in still on process.


Results
=======
Any conbination of the following behaviours:

i. The results will appear multiple times
ii. An error message will appear ("There was a problem communicating with the server, please try again")
iii. The browser will hang, at least until all results are dumped into the page
iv. Weird lines and unexpected graphical garbage will appear on that page

For instance, if your search string has more than 10 results (like when searching the string "neutron"), I expect up to 10 results for this string search due to [1], however by clicking the "Search" button 4 times in a raw before the results acctually appear - 40 results are produced which are the same 10 results appear 4 times.


Expected behaviour
==================
The "Search" results button should be grayed out when a search is still processing.
A "Please wait" label should appear at that time.
A "No results" label should appear when a search ended successfully without results.
Jscript should not handle more than one search query at a time.


[1] The results limit defined in:
"url: 'https://' + strata_hostname + '/rs/problems?limit=10&redhat_client=redhat-access-plugin-openstack_4.0.0-0',"
which is located here:
/usr/lib/python2.6/site-packages/redhat_access_plugin_openstack/static/redhat_access_plugin_openstack/js/redhat_access_plugin_openstack.js

Comment 3 Dan Varga 2014-04-24 22:49:51 UTC
This will be fixed along with https://bugzilla.redhat.com/show_bug.cgi?id=1082762

Comment 4 Ido Ovadia 2014-06-05 12:34:51 UTC
Verified:
=========
python-django-horizon-2014.1-7.el7ost.noarch

Comment 7 errata-xmlrpc 2014-07-08 15:41:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html


Note You need to log in before you can comment on or make changes to this bug.