Bug 1044502 - [abrt] dnf: base.py:125:_add_repo_to_sack:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 113: ordinal not in range(128)
[abrt] dnf: base.py:125:_add_repo_to_sack:UnicodeDecodeError: 'ascii' codec c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Zdeněk Pavlas
Fedora Extras Quality Assurance
abrt_hash:e35f769e2cbb7ac4e1e9f04c67b...
:
: 1046661 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-18 08:13 EST by Evgeny
Modified: 2014-02-02 17:30 EST (History)
7 users (show)

See Also:
Fixed In Version: dnf-0.4.10-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-04 14:53:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.35 KB, text/plain)
2013-12-18 08:13 EST, Evgeny
no flags Details
File: environ (72 bytes, text/plain)
2013-12-18 08:13 EST, Evgeny
no flags Details

  None (edit)
Description Evgeny 2013-12-18 08:13:23 EST
Description of problem:
message came after boot the system

Version-Release number of selected component:
dnf-0.4.9-1.fc20

Additional info:
reporter:       libreport-2.1.10
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.11.10-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
base.py:125:_add_repo_to_sack:UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 113: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 260, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 63, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 122, in _main
    result, resultmsgs = cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1471, in run
    return self.command.doCommand(self.base.basecmd, self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 953, in doCommand
    self.base.fill_sack() # performs the md sync
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 214, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 125, in _add_repo_to_sack
    msg = _("%s, disabling.") % str(e)
UnicodeDecodeError: 'ascii' codec can't decode byte 0xd0 in position 113: ordinal not in range(128)

Local variables in innermost frame:
repo: <Repo _local>
hrepo: <_hawkey.Repo object at 0x7f9eaf7a7480>
self: <dnf.cli.cli.BaseCli object at 0x1b4e090>
e: RepoError()
name: '_local'
Comment 1 Evgeny 2013-12-18 08:13:26 EST
Created attachment 838322 [details]
File: backtrace
Comment 2 Evgeny 2013-12-18 08:13:28 EST
Created attachment 838323 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-12-18 08:49:59 EST
The correct fix to this is a str() => ucd() replace, but since this spills all over the code it's going to be a huge patch.
Comment 4 Ales Kozumplik 2014-01-02 03:03:06 EST
*** Bug 1046661 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2014-01-02 05:10:28 EST
dnf-0.4.10-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.10-1.fc20
Comment 6 Fedora Update System 2014-01-03 03:41:57 EST
Package dnf-0.4.10-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.10-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0089/dnf-0.4.10-1.fc20
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2014-01-04 14:53:32 EST
dnf-0.4.10-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.