Bug 1044542 - mate-panel hangs on adding new widget or launcher
mate-panel hangs on adding new widget or launcher
Status: CLOSED DUPLICATE of bug 753882
Product: Fedora
Classification: Fedora
Component: mate-panel (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-18 09:15 EST by mj.wilson.uk
Modified: 2014-01-12 06:43 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-12 06:43:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mj.wilson.uk 2013-12-18 09:15:12 EST
Description of problem:

mate-panel hangs when I add a new widget or launcher.  top reveals that it is using 100% CPU.

.xsession-errors is full of lines like this:

dconf-CRITICAL **: unable to create file '/run/user/1000/dconf/user': Permission denied.  dconf will not work properly.

(It seems it is spamming the log with those errors, causing 100% CPU usage.)

If I kill the process, and attempt to relaunch with:

$ mate-panel --replace

Then the new process gets stuck in the same loop.

If I kill the X server, and log back in, the same thing happens.  The only solution is to reboot.

Version-Release number of selected component (if applicable):

$ rpm -q mate-panel
mate-panel-1.6.1-4.fc20.x86_64

How reproducible:

Every time.


Steps to Reproduce:
1. Log into the MATE desktop.
2. Drag a launcher from the desktop to the top panel, or right-click and add a widget.

Actual results:

Witness mate-panel hanging.

Expected results:

The widget/launcher is added.


Additional info:

Willing to provide more debug info if required.
Comment 1 Wolfgang Ulbrich 2013-12-18 10:37:46 EST
Seems mate-panel is another victim of https://bugzilla.redhat.com/show_bug.cgi?id=753882
Pls read for yourself.
In short, for some reason pam_systemd change the permission of /run/user/1000/dconf/
In result dconf can't write there if you change panel user gsettings and the panel runs in a high load.
Can you post the permissions of the folder. it should be like this (rave is my login name).
[rave@mother ~]$ ls -l /run/user/1000/
insgesamt 0
drwx------ 2 rave rave 60 18. Dez 16:30 dconf
dr-x------ 2 rave rave  0 18. Dez 16:09 gvfs
lrwxrwxrwx 1 root root 17 18. Dez 16:09 X11-display -> /tmp/.X11-unix/X0

If not change permission.
chmod -R 700 /run/user/1000/dconf/
Comment 2 mj.wilson.uk 2013-12-18 13:33:29 EST
Thanks for the quick reply.  I had seen 753882 on a search, but, on the first read, didn't understand how that might be relevant.  On a second read, I can see some links now.

I seem to be able to add widgets and launchers at present.  Thinking it might be a problem with using "su -", I tried the following:

$ ls -l /run/user/1000
total 0
drwx------. 2 matthew matthew 40 Dec 18 18:18 dconf
dr-x------. 3 matthew matthew  0 Dec 18 14:06 gvfs
drwx------. 2 matthew matthew 80 Dec 18 14:06 pulse
drwxr-xr-x. 2 matthew matthew 60 Dec 18 14:06 systemd
lrwxrwxrwx. 1 root    root    17 Dec 18 14:06 X11-display -> /tmp/.X11-unix/X0

(All looks fine to me.)

$ su -
Password: 
Last login: Wed Dec 18 13:48:57 GMT 2013 on pts/0
# ls -l /run/user/1000
ls: cannot access /run/user/1000/gvfs: Permission denied
total 0
drwx------. 2 matthew matthew 40 Dec 18 18:20 dconf
d?????????? ? ?       ?        ?            ? gvfs
drwx------. 2 matthew matthew 80 Dec 18 14:06 pulse
drwxr-xr-x. 2 matthew matthew 60 Dec 18 14:06 systemd
lrwxrwxrwx. 1 root    root    17 Dec 18 14:06 X11-display -> /tmp/.X11-unix/X0

(OK, that's strange.  Why can't it access gvfs?)

# logout

$ ls -l /run/user/1000
total 0
drwx------. 2 matthew matthew 40 Dec 18 18:20 dconf
dr-x------. 3 matthew matthew  0 Dec 18 14:06 gvfs
drwx------. 2 matthew matthew 80 Dec 18 14:06 pulse
drwxr-xr-x. 2 matthew matthew 60 Dec 18 14:06 systemd
lrwxrwxrwx. 1 root    root    17 Dec 18 14:06 X11-display -> /tmp/.X11-unix/X0

(All looks fine, again.)

Even after this, it seems to be possible to alter mate-panel's configuration (by adding widgets).  So, I can't seem to reproduce it reliably.

When it next happens, I'll check the permissions as above.
Comment 3 Wolfgang Ulbrich 2014-01-12 06:43:00 EST

*** This bug has been marked as a duplicate of bug 753882 ***

Note You need to log in before you can comment on or make changes to this bug.