Bug 1044580 - KeyError: 'EPEL5': FedoraReview/plugins/generic_should.py", line 80
Summary: KeyError: 'EPEL5': FedoraReview/plugins/generic_should.py", line 80
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-review
Version: 20
Hardware: noarch
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1046917 1053678 (view as bug list)
Depends On:
Blocks: 1023848
TreeView+ depends on / blocked
 
Reported: 2013-12-18 15:34 UTC by Jiri Popelka
Modified: 2014-01-28 21:05 UTC (History)
10 users (show)

Fixed In Version: fedora-review-0.5.1-2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-15 06:02:43 UTC


Attachments (Terms of Use)
fedora-review.log (5.76 KB, text/plain)
2013-12-18 15:34 UTC, Jiri Popelka
no flags Details

Description Jiri Popelka 2013-12-18 15:34:45 UTC
Created attachment 838409 [details]
fedora-review.log

Steps to Reproduce:
1. install fedora-review-0.5.1-1.fc20.noarch
2. download spec&srpm from bug #970393
3. fedora-review -n foo2zjs

Actual results:
INFO: Processing local files: foo2zjs
INFO: Getting .spec and .srpm Urls from : Local files in /home/jpopelka/Documents/package_review
INFO:   --> SRPM url: file:///home/jpopelka/Documents/package_review/foo2zjs-0.20130813-1.fc19.src.rpm
INFO:   --> Spec url: file:///home/jpopelka/Documents/package_review/foo2zjs.spec
INFO: Using review directory: /home/jpopelka/Documents/package_review/review-foo2zjs
ERROR: chroot /var/lib/mock/fedora-20-x86_64/root/ not initialized!
INFO: Re-initializing mock build root
ERROR: Exception down the road...(logs in /home/jpopelka/.cache/fedora-review.log)

Comment 1 Stanislav Ochotnicky 2013-12-18 16:20:50 UTC
Hmm, I can't reproduce this though I have some idea why this might happen. Will need to look into it more

Comment 2 Michael Schwendt 2013-12-20 23:36:04 UTC
Ran "fedora-review -b 1012391" and got the same traceback.

Comment 3 Michael Schwendt 2013-12-24 10:45:30 UTC
Even "fedora-review --display-flags" fails:

12-24 11:43 root         DEBUG    fedora-review 0.5.1 bb9bf27 2013-12-13 12:40:49 +0100 started
12-24 11:43 root         DEBUG    Command  line: /usr/bin/fedora-review --display-flags
12-24 11:43 root         DEBUG    Exception down the road...
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 232, in run
    self._do_run(outfile)
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 202, in _do_run
    self._list_flags()
  File "/usr/lib/python2.7/site-packages/FedoraReview/review_helper.py", line 124, in _list_flags
    checks_lister = ChecksLister()
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks.py", line 258, in __init__
    _ChecksLoader.__init__(self)
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks.py", line 166, in __init__
    self._load_checks()
  File "/usr/lib/python2.7/site-packages/FedoraReview/checks.py", line 204, in _load_checks
    tests = registry.register(plugin)
  File "/usr/lib/python2.7/site-packages/FedoraReview/registry.py", line 130, in register
    obj = (c[1])(self.checks)
  File "/usr/lib/python2.7/site-packages/FedoraReview/plugins/generic_should.py", line 80, in __init__
    if self.flags['EPEL5']:
KeyError: 'EPEL5'
12-24 11:43 root         ERROR    Exception down the road...(logs in /home/ms20b/.cache/fedora-review.log)
12-24 11:43 root         DEBUG    Report completed:  0.023 seconds


$ fedora-review -d
ERROR: Exception down the road...(logs in /home/ms20b/.cache/fedora-review.log)

Same there.

Comment 4 Michael Schwendt 2013-12-24 10:47:46 UTC
Using "yum downgrade fedora-review" as a work-around.

  Installing : fedora-review-0.5.0-3.fc20.noarch                            1/2 
  Cleanup    : fedora-review-0.5.1-1.fc20.noarch                            2/2 
  Verifying  : fedora-review-0.5.0-3.fc20.noarch                            1/2 
  Verifying  : fedora-review-0.5.1-1.fc20.noarch                            2/2

Comment 5 Alec Leamas 2013-12-27 14:57:30 UTC
*** Bug 1046917 has been marked as a duplicate of this bug. ***

Comment 6 Alec Leamas 2013-12-27 17:20:53 UTC
I have checked in a fix for this on the devel and release-0.5.1 branches:
https://git.fedorahosted.org/cgit/FedoraReview.git/commit/?id=c348fe6ff9ac6bd40961d565a3fc76aecbd92a1a

It's not fully verified, but is ATM in the Works For Me (TM) state.

Comment 7 Igor Gnatenko 2013-12-27 18:53:40 UTC
yes.this patch fixes bug. Thanks. ;) I've wrote bad patch.

Comment 8 Jeff Peeler 2014-01-02 22:22:27 UTC
This fix seems to have worked for me as well.

Comment 9 Orion Poplawski 2014-01-06 20:47:14 UTC
Seems to fix it for me too, though I'm seeing a new error as well.

Comment 10 Remi Collet 2014-01-11 07:35:52 UTC
Same issue on F19.

Patch from comment #6 also fixes the issue, "for me"(tm)

Comment 11 Fedora Update System 2014-01-13 10:04:25 UTC
fedora-review-0.5.1-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-2.fc20

Comment 12 Fedora Update System 2014-01-13 10:04:38 UTC
fedora-review-0.5.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-2.fc19

Comment 13 Fedora Update System 2014-01-13 10:04:50 UTC
fedora-review-0.5.1-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.5.1-2.el6

Comment 14 Fedora Update System 2014-01-13 20:08:21 UTC
Package fedora-review-0.5.1-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fedora-review-0.5.1-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0153/fedora-review-0.5.1-2.el6
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2014-01-15 06:02:43 UTC
fedora-review-0.5.1-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Stanislav Ochotnicky 2014-01-15 16:01:53 UTC
*** Bug 1053678 has been marked as a duplicate of this bug. ***

Comment 17 Fedora Update System 2014-01-22 23:07:37 UTC
fedora-review-0.5.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2014-01-28 21:05:23 UTC
fedora-review-0.5.1-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.