Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1044610 - Can't change background using org.gnome.desktop.background.gschema.override on baremetal machine
Summary: Can't change background using org.gnome.desktop.background.gschema.override o...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.0
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 7.0
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1070285
TreeView+ depends on / blocked
 
Reported: 2013-12-18 16:44 UTC by Martin
Modified: 2014-09-15 00:04 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-25 08:07:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin 2013-12-18 16:44:47 UTC
Can't change background using org.gnome.desktop.background.gschema.override on baremetal machine.

I tested this on 2 VMs and 2 baremetal machines.

Version-Release number of selected component (if applicable):
RHEL-7.0-20131127.1 with latest updates

Steps to Reproduce: 
Have baremetal machine with RHEL7 installed.


 1. Download wallpaper: cd /usr/share/backgrounds/; wget http://wallupload.com/
    wp-content/uploads/2013/03/RedHat-With-Cool-Wallpaper.png
 2. Using your favorite editor create override file in: /usr/share/glib-2.0/
    schemas/org.gnome.desktop.background.gschema.override
 3. Paste: [org.gnome.desktop.background]
    picture-uri='file:///usr/share/backgrounds/RedHat-With-Cool-Wallpaper.png'
 4. Run as a superuser: glib-compile-schemas /usr/share/glib-2.0/schemas/
 5. Logout and login again.



Actual results: 
Background doesn't change.

Expected results:
Wallpaper image on all desktops and monitors should be changed to selected
image.

Comment 2 Florian Müllner 2013-12-20 17:04:45 UTC
Does

  gsettings get org.gnome.desktop.background picture-uri

show the expected result?

Comment 3 Martin 2013-12-20 17:06:07 UTC
Yes.

Comment 4 Vladimir Benes 2014-02-11 13:53:42 UTC
Florian,
do you plan to fix this one in the pre RC phase? We are really close to exception process so we should have this at least acked

Comment 5 Florian Müllner 2014-02-13 16:26:39 UTC
(In reply to Martin Holec from comment #0)
> Can't change background using org.gnome.desktop.background.gschema.override
> on baremetal machine.
> 
> [...]
>
>  2. Using your favorite editor create override file in: /usr/share/glib-2.0/
>     schemas/org.gnome.desktop.background.gschema.override

Oh, so here's another observation:
The default background is already set using an override file, so unless you remove /usr/share/glib-2.0/schemas/10_org.gnome.desktop.background.default.gschema.override, you'll end up with two conflicting settings. Does it work if you change the existing override instead of creating a new file?

Comment 6 Florian Müllner 2014-02-13 16:33:13 UTC
(In reply to Vladimir Benes from comment #4)
> do you plan to fix this one in the pre RC phase?

To be honest, I don't think this is a bug in gnome-shell - there is no special treatment of this particular setting, so if the problem is not the observation in comment #5, then something is wrong with glib's override mechanism (e.g. a glib or dconf issue).


> We are really close to exception process so we should have this at least acked

OK, I've requested the necessary permissions.

Comment 7 Martin 2014-02-17 15:57:37 UTC
(In reply to Florian Müllner from comment #5)
> (In reply to Martin Holec from comment #0)
> > Can't change background using org.gnome.desktop.background.gschema.override
> > on baremetal machine.
> > 
> > [...]
> >
> >  2. Using your favorite editor create override file in: /usr/share/glib-2.0/
> >     schemas/org.gnome.desktop.background.gschema.override
> 
> Oh, so here's another observation:
> The default background is already set using an override file, so unless you
> remove
> /usr/share/glib-2.0/schemas/10_org.gnome.desktop.background.default.gschema.
> override, you'll end up with two conflicting settings. Does it work if you
> change the existing override instead of creating a new file?

This doesn't work either.

Comment 9 Florian Müllner 2014-02-19 12:19:37 UTC
Mmh, I must admit I'm out of ideas for now - I have tested the following in a RHEL-7 VM:

 1. either create a new override file as indicated and remove the existing one,
    or change the existing file to reference a different image
 2. run glib-compile-schemas /usr/share/glib-2.0/schemas
 3. log out + log in again

In both cases I get the new background as expected :-(

Comment 10 Florian Müllner 2014-02-21 15:56:13 UTC
(In reply to Florian Müllner from comment #9)
> Mmh, I must admit I'm out of ideas for now

So here is another one (thanks Matthias!) - the override only affects the default setting, so if you changed the setting at some point in the past, the changed default value will not take effect.
Does "gsettings reset org.gnome.desktop.background picture-uri" make a difference?

Comment 11 Martin 2014-02-21 16:29:25 UTC
(In reply to Florian Müllner from comment #10)
> (In reply to Florian Müllner from comment #9)
> > Mmh, I must admit I'm out of ideas for now
> 
> So here is another one (thanks Matthias!) - the override only affects the
> default setting, so if you changed the setting at some point in the past,
> the changed default value will not take effect.
> Does "gsettings reset org.gnome.desktop.background picture-uri" make a
> difference?

This works for me.

Comment 12 Florian Müllner 2014-02-21 17:04:56 UTC
(In reply to Martin Holec from comment #11)
> This works for me.

Great! So does the test case in the description now work as expected? Can we close this bug?


Note You need to log in before you can comment on or make changes to this bug.