Bug 104465 - libgsf fails to rebuild because gcc-3 segfaults
libgsf fails to rebuild because gcc-3 segfaults
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 17:36 EDT by Richard Offer
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 16:13:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gcc -save-temps output as requested (243.51 KB, text/plain)
2003-09-17 19:03 EDT, Richard Offer
no flags Details

  None (edit)
Description Richard Offer 2003-09-15 17:36:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516
Mozilla Firebird/0.6

Description of problem:
Trying to rebuild libgsf fails on IA64 using gcc 3. It compiles okay using gcc296


gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wall -Wunused
-Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED
-Wno-system-headers -W -Wfloat-equal -Wpointer-arith -Wbad-function-cast
-Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute
-Wnested-externs -Wunreachable-code -Winline -D_POSIX_SOURCE -D__EXTENSIONS__
-D_BSD_SOURCE -c gsf-infile-zip.c  -fPIC -DPIC -o .libs/gsf-infile-zip.lo
gsf-infile-zip.c: In function `vdir_insert':
gsf-infile-zip.c:118: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [gsf-infile-zip.lo] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/libgsf-1.6.0/gsf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/libgsf-1.6.0'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.13925 (%build)


While on the subject of libgsf, Beta1 fails to include the libgsf-devel package,
which is required to rebuild a number
of other packages.



Version-Release number of selected component (if applicable):
libgsf-1.6.0-4

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild --rebuild libgsf-1.6.0-4.src.rpm

Actual Results:  ....

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wall -Wunused
-Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED
-Wno-system-headers -W -Wfloat-equal -Wpointer-arith -Wbad-function-cast
-Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute
-Wnested-externs -Wunreachable-code -Winline -D_POSIX_SOURCE -D__EXTENSIONS__
-D_BSD_SOURCE -c gsf-infile-msvba.c  -fPIC -DPIC -o .libs/gsf-infile-msvba.lo
gsf-infile-msvba.c: In function `vba3_dir_read':
gsf-infile-msvba.c:256: warning: passing arg 3 of `vba_inflate' from
incompatible pointer type
gsf-infile-msvba.c:244: warning: unused variable `data'
gsf-infile-msvba.c:245: warning: unused variable `size'
gsf-infile-msvba.c:441:2: warning: #warning TODO
gsf-infile-msvba.c:468:2: warning: #warning TODO
/usr/include/bits/string2.h: At top level:
gsf-infile-msvba.c:140: warning: `vba3_dirent_read' defined but not used
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wall -Wunused
-Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED
-Wno-system-headers -W -Wfloat-equal -Wpointer-arith -Wbad-function-cast
-Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute
-Wnested-externs -Wunreachable-code -Winline -D_POSIX_SOURCE -D__EXTENSIONS__
-D_BSD_SOURCE -c gsf-infile-msvba.c -o gsf-infile-msvba.o >/dev/null 2>&1
mv -f .libs/gsf-infile-msvba.lo gsf-infile-msvba.lo
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I..
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2     
-O2 -g -pipe -Wall -Wunused -Wmissing-prototypes -Wmissing-declarations 
-DG_DISABLE_DEPRECATED -Wno-system-headers -W -Wfloat-equal -Wpointer-arith
-Wbad-function-cast -Wwrite-strings -Wsign-compare -Waggregate-return
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wmissing-format-attribute -Wnested-externs -Wunreachable-code -Winline
-D_POSIX_SOURCE -D__EXTENSIONS__ -D_BSD_SOURCE -c gsf-infile-zip.c
rm -f .libs/gsf-infile-zip.lo
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wall -Wunused
-Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED
-Wno-system-headers -W -Wfloat-equal -Wpointer-arith -Wbad-function-cast
-Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute
-Wnested-externs -Wunreachable-code -Winline -D_POSIX_SOURCE -D__EXTENSIONS__
-D_BSD_SOURCE -c gsf-infile-zip.c  -fPIC -DPIC -o .libs/gsf-infile-zip.lo
gsf-infile-zip.c: In function `vdir_insert':
gsf-infile-zip.c:118: internal error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
make[2]: *** [gsf-infile-zip.lo] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/libgsf-1.6.0/gsf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/libgsf-1.6.0'
make: *** [all-recursive-am] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.13925 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.13925 (%build)


Expected Results:  A built RPM

Additional info:

The following change worked and successfully built libgsf pacakge

--- libgsf.spec.as30    2003-09-12 14:25:45.000000000 -0700
+++ libgsf.spec 2003-09-12 14:27:00.000000000 -0700
@@ -32,7 +32,7 @@
 %setup
 
 %build
-%configure
+CC=gcc296 ./configure --host=ia64-unknown-linux-gnu
--build=ia64-unknown-linux-gnu --target=ia64-redhat-linux-gnu
--program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
--sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
--includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec
--localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man
--infodir=/usr/share/info
 make
 
 %install

This change isn't proposed as a fix, since it is platform specific, but it shows
how I got a working pacakge built...
Comment 1 Jakub Jelinek 2003-09-17 18:22:43 EDT
Please rerun:
gcc -save-temps -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include/glib-2.0 \
-I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -O2 -g -pipe -Wall -Wunused \
-Wmissing-prototypes -Wmissing-declarations -DG_DISABLE_DEPRECATED \
-Wno-system-headers -W -Wfloat-equal -Wpointer-arith -Wbad-function-cast \
-Wwrite-strings -Wsign-compare -Waggregate-return -Wstrict-prototypes \
-Wmissing-prototypes -Wmissing-declarations -Wmissing-format-attribute \
-Wnested-externs -Wunreachable-code -Winline -D_POSIX_SOURCE -D__EXTENSIONS__ \
-D_BSD_SOURCE -c gsf-infile-zip.c  -fPIC -DPIC -o .libs/gsf-infile-zip.lo

(note -save-temps option) and attach here gsf-infile-zip.i it creates.
Comment 2 Richard Offer 2003-09-17 19:03:00 EDT
Created attachment 94575 [details]
gcc -save-temps output as requested
Comment 3 Jakub Jelinek 2003-09-21 17:40:54 EDT
Cannot reproduce this with gcc-3.2.3-20.

Note You need to log in before you can comment on or make changes to this bug.