Bug 1044761 - Upgrade 19->20 fails using fedup-0.8.0-3.fc19 with UEFI
Summary: Upgrade 19->20 fails using fedup-0.8.0-3.fc19 with UEFI
Keywords:
Status: CLOSED DUPLICATE of bug 1045864
Alias: None
Product: Fedora
Classification: Fedora
Component: fedup
Version: 19
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Will Woods
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 23:04 UTC by Vareg
Modified: 2014-01-23 23:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 23:50:11 UTC
Type: Bug


Attachments (Terms of Use)
The output that journalctl -n 4000 gives (277.36 KB, text/plain)
2013-12-18 23:04 UTC, Vareg
no flags Details
low-res image depicting where system freezes - part 1 (551.83 KB, image/jpeg)
2013-12-19 14:53 UTC, Vareg
no flags Details
low-rez image depicting where system freezes - part 2 (595.64 KB, image/jpeg)
2013-12-19 14:53 UTC, Vareg
no flags Details

Description Vareg 2013-12-18 23:04:16 UTC
Created attachment 838680 [details]
The output that journalctl -n 4000 gives

Description of problem:

- Laptop is an HP g6 2333er with AMD 64 + radeon x70000.

- I've been trying to update from Fedora 19 to Fedora 20 using fedup-0.8.0-3.fc1

- Running sudo fedup --network 20 goes pretty well, if not for two three warnings and broken kernel dependencies related to my kmod-catalyst drivers

- Upon reboot, the upgrade menu is available but after only throwing a few lines, the system attempts booting on Fedora 19 Schroedinger's cat and fails to go to the end, while freezing at 'mounted /boot/efi'

- I then can only reboot manually holding the power button
 long enough(a few seconds are enough)

- Once rebooting, i can choose my usual kernel(which has become second choice) and boot normally without any problem, 


Version-Release number of selected component (if applicable):


How reproducible:
100% reproducible

Steps to Reproduce:
1. Reboot comp
2. Choose the first entry in Grub - Upgrading via fedup 
3. Wait until the system freezes

Actual results:
freezes at mounted /boot/efi

Expected results:
my system upgraded to Fedora 20 with no issues whatsoever.

Additional info:
attached to this report is a copy of the output that journalctl -n 4000 gives

Comment 1 Chris Murphy 2013-12-18 23:26:04 UTC
The attached journal doesn't show boot from the fedup kernel and initramfs. I'd like to see a lowrez photo attached of the screen at the time of the freeze. So you will need to rerun fedup in order to get the proper fedup boot option in GRUB.

Comment 2 Vareg 2013-12-18 23:33:53 UTC
Hi, i've attached the output of journalctl because AdamW thought it would contain events related to the upgrade. Now by lowrez photo you mean that i should actually take a camera and shoot the screen when the system freezes? 

rerun fedup in order to get the proper fedup boot option in GRUB? What do you mean exactly?

Comment 3 Chris Murphy 2013-12-18 23:48:58 UTC
I just did a UEFI install of F18 and upgraded with fedup to F20. After completion the journal doesn't contain any information during the upgrade, so I don't think the upgrade environment systemd is writing to persistent storage. And in any case, your crash likely occurred before rootfs was remounted read-write so I don't think we're going to find any useful information recorded anywhere.

So yes, a low resolution (small file) JPEG like from a cell phone camera is fine. And yes I'm assuming the Fedup option isn't in the GRUB menu anymore, but if it is, you can just try that rather than re-running fedup.

Comment 4 Chris Murphy 2013-12-18 23:50:39 UTC
Also can you check your computer model with the manufacturer and see if the UEFI firmware is current?

Comment 5 Geerten Schram 2013-12-19 12:57:58 UTC
I've the same problem on a Dell Inspirion 15 - 3521. Boot of the fedup kernel stops at mounting /boot/efi. UEFI boot enabled, secure boot off. F19 works. Fedup to 20 not.

If you need more info. Please let me know.

Comment 6 Vareg 2013-12-19 14:53:10 UTC
Created attachment 839008 [details]
low-res image depicting where system freezes - part 1

Comment 7 Vareg 2013-12-19 14:53:49 UTC
Created attachment 839009 [details]
low-rez image depicting where system freezes - part 2

Comment 8 Vareg 2013-12-19 15:01:57 UTC
Hi Chris, i've just uploaded two pics showing where it freezes. Now as to the UEFI Firmware check, where can i even find what version is running

Comment 9 Vareg 2013-12-19 15:03:07 UTC
@Geerten safe boot is not enabled on my box either

Comment 10 Vareg 2013-12-19 15:11:26 UTC
okay, i think UEFI version is Hynside 20 rev 3.7

Comment 11 Vareg 2013-12-19 15:22:07 UTC
but in any case, the manufacturer being HP, i will never get anything to update the bios or anything else unless i run Windows...so i can only do with what i have.

Now, aren't there any places at all in the system where there's a trace of what's going on when booting the upgrade?

Comment 12 Chris Murphy 2013-12-19 17:18:43 UTC
F.26 is the current version:
http://h10025.www1.hp.com/ewfrf/wc/softwareDownloadIndex?softwareitem=ob-116222-1&cc=us&dlc=en&lc=en&os=4132&product=5359870&sw_lang=

Do you have /var or /home on a Logical Volume or encrypted? If yes to /home, try editing /etc/fstab and commenting out /home, rebooting and choosing the system upgrade (fedup) option in the grub menu, and see if it proceeds with the upgrade. After the upgrade, you'll want to uncomment /home from fstab and reboot.

Comment 13 Vareg 2013-12-19 22:00:58 UTC
Okay, so i have followed your advice because yes i have an encrypted /home and the fstab move was right but there's a lot more to it in fact. Let me explain that to you, meanwhile please note that i'm typing this from an old laptop, very old because the test one is not very functional right away...

So to make a long story short, the upgrade almost makes it if i change my kernel parameters, removing all that's radeon, and adding selinux=0, but freezes at 'Started gnome display manager'. Before that, we can find 'Started builds and install new kmods from akmod packages'

When i boot fedora 19 now, i don't get my normal system anymore, i get fedora 20 trying to make it but i get a black screen, just plain black, when it attempts to launch the login prompt, so i guess it's all a graphic driver/kernel problem?

fedup did warn me about catalyst broken dependencies but i did not think this would get that far in failure.

Last but not least, modifying fstab wasn't enough to launch the upgrade process, it first froze on something i can't remember what it read, then, trying to reboot by doing ctrl+alt+del, the script did something i can't explain and the update process started, upgrading over 1800 packages. Only 4-5 minor warnings and only one error with Anjuta, which i don't even use since i prefer my old Crimson editor... so i take it the upgrade process went well, if not for what went on afterwards.

But now, i'm stuck wondering what to do next, because i'm out of ideas and i need my system running, at least for work. So, either i wait for someone here to give me the extra push, or i do a clean install and reinject my backup data.

What do you think i should do now?

Comment 14 Chris Murphy 2013-12-23 03:11:43 UTC
Can you successfully boot the Fedora 20 Live Desktop ISO?

Comment 15 Vareg 2013-12-26 12:41:15 UTC
well no, because of the gflrx driver....otherwise, if i had had a generic graphic card i reckon yes, should have been okay in the end. So there's still some useful info here anyway for whoever encounters problems with uefi boot and/or selinux.
Now, problem is that support for the radeon catalyst kmod driver has been dropped for F20, and i haven't found a way to make catalyst for F19 work in F20. At some point during the dependency check process yum says it needs a lesser kernel.

So, in the end, i'm back on F19, works for me, i will consider upgrading when support for catalyst will go on again.

Comment 16 Will Woods 2014-01-23 22:14:51 UTC
Okay so it sounds like you hit:

* bug 1045864 (hang with multiple LUKS partitions)
* maybe bug 1044484 (hang on systems with SELinux disabled)
* possibly also bug 1045168 (upgrade doesn't start on systems with separate /var)

It also sounds like once you got past that stuff, the upgrade happened successfully, except for some problems with ATI's proprietary video stuff.

Does that sound right? If so, I'm going to close this bug, since we already have open bugs for all the problems you saw and I can't fix ATI stuff.

Comment 17 Vareg 2014-01-23 22:22:40 UTC
not sure i had been hitting the third one but the first ones yeah i did.
About ATI, we're not talking about the proprietary driver, we're talking about the kmod-catalyst version originaly maintained by Leigh, who gave it up.
Otherwise this bug has no reason not to be closed indeed yeah

Comment 18 Will Woods 2014-01-23 23:50:11 UTC

*** This bug has been marked as a duplicate of bug 1045864 ***


Note You need to log in before you can comment on or make changes to this bug.