Bug 1044768 - Zanata does not pull the latest changes in translation due to unchanged ETags
Zanata does not pull the latest changes in translation due to unchanged ETags
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
3.1
Unspecified Unspecified
high Severity high
: ---
: 3.3
Assigned To: Sean Flanigan
Zanata-QA Mailling List
: Reopened
Depends On:
Blocks: 1066782
  Show dependency treegraph
 
Reported: 2013-12-18 18:40 EST by Yuko Katabami
Modified: 2014-03-20 01:47 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.3.2-SNAPSHOT (20140227-1648)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-20 01:47:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2013-12-18 18:40:29 EST
Description of problem:
When I run "mvn org.zanata:zanata-maven-plugin:pull", it does not pull the latest changes in translation, with messages "No changes in translations for xxx" for all files.
I am using zanata-maven-plugin:3.0.1

Version-Release number of selected component (if applicable): 3.1.2


How reproducible: 100%


Steps to Reproduce:
1. Make a change in translation in zanata
2. Run "$ mvn org.zanata:zanata-maven-plugin:pull"
3. Check the output.

Actual results:
It prints the following output:

Are you sure (y/n)? y
[INFO] No changes in translations for locale ja and document Appendix
[INFO] No changes in translations for locale ja and document Author_Group
[INFO] No changes in translations for locale ja and document Book_Info
[INFO] No changes in translations for locale ja and document Converting_VMs_KVM
[INFO] No changes in translations for locale ja and document Converting_VMs_RHEV
[INFO] No changes in translations for locale ja and document Debugging
[INFO] No changes in translations for locale ja and document Feedback
[INFO] No changes in translations for locale ja and document Installing
[INFO] No changes in translations for locale ja and document Introduction
[INFO] No changes in translations for locale ja and document P2V_migration
[INFO] No changes in translations for locale ja and document Preface
[INFO] No changes in translations for locale ja and document References
[INFO] No changes in translations for locale ja and document Revision_History
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 14.960s
[INFO] Finished at: Thu Dec 19 09:28:13 EST 2013
[INFO] Final Memory: 8M/141M
[INFO] ------------------------------------------------------------------------

Local build does not have the changes applied either.

Expected results:
Are you sure (y/n)? y
[INFO] Writing translation file in locale ja-JP for document Appendix
[INFO] Writing translation file in locale ja-JP for document Author_Group
[INFO] Writing translation file in locale ja-JP for document Book_Info
[INFO] Writing translation file in locale ja-JP for document Converting_VMs_KVM
[INFO] Writing translation file in locale ja-JP for document Converting_VMs_RHEV
[INFO] Writing translation file in locale ja-JP for document Debugging
[INFO] Writing translation file in locale ja-JP for document Feedback
[INFO] Writing translation file in locale ja-JP for document Installing
[INFO] Writing translation file in locale ja-JP for document Introduction
[INFO] Writing translation file in locale ja-JP for document P2V_migration
[INFO] Writing translation file in locale ja-JP for document Preface
[INFO] Writing translation file in locale ja-JP for document References
[INFO] Writing translation file in locale ja-JP for document Revision_History
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 32.221s
[INFO] Finished at: Thu Dec 19 09:30:59 EST 2013
[INFO] Final Memory: 8M/110M
[INFO] ------------------------------------------------------------------------


Additional info:
Running the command with -Dzanata.useCache=false fixes the problem.
Comment 2 Carlos Munoz 2013-12-18 18:52:03 EST
This seems to be related to the cache, as removing the cache directory or using the 'useCache=false' option solves the problem.
Comment 3 Carlos Munoz 2014-01-13 02:15:27 EST
Yuko, I wasn't able to replicate this issue, although I did manage to find an issue with the handling of cached files. Have you seen this happen recently?
Comment 5 Carlos Munoz 2014-01-13 18:59:45 EST
After attempting to debug this issue both locally in dev and test environments, and together with Yuko with production systems, we were not able to reproduce it.
Closing this issue.
Comment 7 Hedda Peters 2014-02-16 17:47:33 EST
It is happening right now in above project. 
I'll be in the office tomorrow (Tue) in case you want to have a look at what's happening on my machine.
Comment 8 Carlos Munoz 2014-02-16 19:02:34 EST
Assigning to Damian for triage.
Comment 9 Carlos Munoz 2014-02-16 19:04:18 EST
Hedda, have you tried the proposed workaround above? (Using the 'useCache=false' option)
Comment 10 Hedda Peters 2014-02-16 22:19:21 EST
(In reply to Carlos Munoz from comment #9)
> Hedda, have you tried the proposed workaround above? (Using the
> 'useCache=false' option)

I haven't tried this workaround, but I am aware of it.

I don't urgently need to pull the translations for this project, so I won't try this workaround for now - in case one of you guys wants to have a look at what's going on on my machine when I'm in the office tomorrow.
Comment 14 Sean Flanigan 2014-02-24 01:33:45 EST
https://github.com/zanata/zanata-server/pull/384
Comment 16 Ding-Yi Chen 2014-02-26 19:44:33 EST
Bug confirmed as I managed to reproduced this bug in Zanata version 3.2.3 (20140120-0038)

Step to reproduce:
0. Assume the zanata.xml for the project is set up.
1. Find a podir (or gettext) project.
2. Edit a translation entry to become fuzzy.
3. mvn org.zanata:zanata-maven-plugin:pull
4. Edit that translation entry to become translated.
5. mvn org.zanata:zanata-maven-plugin:pull
6. View the changed entry in downloaded files.

Actual:
The changed entry was still fuzzy.

Expected:
The changed entry should be updated as translated.
Comment 17 Ding-Yi Chen 2014-02-27 22:15:33 EST
VERIFIED with Zanata 3.3.2-SNAPSHOT (20140227-1648)
Comment 18 Sean Flanigan 2014-03-20 01:47:14 EDT
Closing VERIFIED bugs for Zanata server 3.3.2.

Note You need to log in before you can comment on or make changes to this bug.