Bug 104479 - unable to set kernel configuration via KDE Control center
Summary: unable to set kernel configuration via KDE Control center
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kdeadmin   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-16 04:50 UTC by Elton Woo
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-14 14:43:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elton Woo 2003-09-16 04:50:20 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
KDE control center does not allow kernel configuration,
but instead pops up an error message to the effect that:
"The kernel configuration could not be read due to the following error: 

/usr/src/linux-2.4/drivers/net/wan/Config.in, line 84:

 
        then
^ parse error

Either your kernel sources contain invalid configuration rules or you just found
a bug in the KDE Kernel Configurator."

 

Version-Release number of selected component (if applicable):
kdeadmin-3.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Open KDE Control Panel
2. Select System Administration, and Linux Kernel
3. 
    

Actual Results:  Above mentioned error shows in window.

Expected Results:  First, the dialog window should (must) have the requirement
"Administrator mode" ... since, logically the user should 
not have access to modifying the kernel options.
The selection dialog buttons "Load from" and "save as"
should not be greyed out, but should be functional

Additional info:

Comment 1 Ngo Than 2005-04-14 14:43:30 UTC
the KDE Kernel Configurator module is broken and was already removed in
kde-3.2.x upstream


Note You need to log in before you can comment on or make changes to this bug.