Bug 10448 - Checks for "on"/"off" from chkconfig also when using foreign languages
Checks for "on"/"off" from chkconfig also when using foreign languages
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: piranha (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Copeland
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-30 12:20 EST by Trond Eivind Glomsrød
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-30 16:05:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-03-30 12:20:23 EST
piranha uses chkconfig to check the status of certain components, and
checks the return string for "on"/"off". This approach doesn't work when
LANG or LC_ALL has been set.

Workaround: Run piranha like this:

LANG="" LC_ALL="" piranha
Comment 1 Red Hat Bugzilla 2000-03-30 16:05:59 EST
This entry is referring to the piranha X window GUI, which is an obsolete
component and will not appear in future releases of piranha. It was included in
RH Linux 6.2 to help older piranha users migrate to the new web GUI.

Because the component is obsolete, and there is a work-around, this bugzilla
entry is being flagged as WONTFIX.

However a patch has been created to fix this, and a corrected version may appear
on Red Hat's web site (in errata or rawhide) in the future as part of an
upcoming web GUI update. Until then, user's can manually apply the following
patch to 6.2's piranha source code to achieve the same result:


--- piranha/gui/lvs-glue.c      Mon Mar  6 19:30:46 2000
+++ piranha.new/gui/lvs-glue.c  Thu Mar 30 15:19:35 2000
@@ -11,6 +11,10 @@
  * along with this program; if not, write to the Free Software
  * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
  *
+ *
+ *   2000-03-30 - Trond Eivind  Glomsrxd <teg@redhat.com>
+ *                Fixed an i18n problem -
+ *                chkconfig doesn't reply on/off in all languages
  */

 #include "lvs-glue.h"
@@ -586,8 +590,9 @@
       break;
     }

-
-  f = popen("/sbin/chkconfig --list", "r");
+  /* Unset LC_ALL and LANG to avoid some i18n problems */

+
+  f = popen("LC_ALL=\"\" LANG=\"\" /sbin/chkconfig --list", "r");

   if (f == NULL)
     {
Comment 2 Red Hat Bugzilla 2000-04-18 11:21:59 EDT
FYI: The patch will appear in next release.
It will not be posted to errata, but may
appear in rawhide in the future.
Comment 3 Red Hat Bugzilla 2000-04-27 14:30:59 EDT
Another Update: Since this GUI is being dropped, this patch will not appear in
any future release of piranha. User's experiencing this problem will need to
apply the manual patch shown above.

Note You need to log in before you can comment on or make changes to this bug.