Bug 10449 - sed fails to accurately stream file contents
Summary: sed fails to accurately stream file contents
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sed   
(Show other bugs)
Version: 6.1
Hardware: sparc
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-30 17:54 UTC by Dave Torrey
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-30 18:09:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Torrey 2000-03-30 17:54:41 UTC
sed, as packaged with RH6.1-sparc, as well as a fresh compile of sed-3.02,
fails to function accurately on my SparcClassic.  It would reliably drop
the first character of a file, and append a NULL value to the file on
occasion.  This effectively cripples a system by not allowing configure
or other sed-intensive programs to function properly.

I did manage to make it work by explicitly commenting out a #define in
the sed-3.02 Makefiles:

CPPFLAGS= -D_FILE_OFFSET_BITS=64

On a hunch (since the Classic isn't 64-bit), I commented everything after
the = sign, and it appears to work fine.  It had been causing annoying
problems with autoconf scripts, but doesn't when compiled with this
comment.

I'm not sure what the setting really does, but it might be worth looking
into for future RH-sparc releases.  I'm also not sure if it would be a
problem with sed, autoconf, or the system include files, but it manifests
itself in sed, so here 'tis.

Comment 1 Bill Nottingham 2000-03-30 18:09:59 UTC
This is fixed in 6.2; it's a glibc problem, IIRC.


Note You need to log in before you can comment on or make changes to this bug.