Bug 1044955 - UnicodeDecodeError: 'utf8' codec can't decode byte 0xaf in position 28: invalid start byte [NEEDINFO]
Summary: UnicodeDecodeError: 'utf8' codec can't decode byte 0xaf in position 28: inval...
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:069d69b067ec9e716c052cfa628...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-19 10:04 UTC by Piotr
Modified: 2014-01-23 21:12 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 21:12:00 UTC
Type: ---
dshea: needinfo? (nmf1)


Attachments (Terms of Use)
File: anaconda-tb (1.86 MB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: anaconda.log (29.18 KB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: environ (517 bytes, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: journalctl (785.34 KB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: lsblk_output (3.40 KB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: nmcli_dev_list (10.57 KB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: os_info (375 bytes, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: program.log (190.68 KB, text/plain)
2013-12-19 10:04 UTC, Piotr
no flags Details
File: storage.log (886.54 KB, text/plain)
2013-12-19 10:05 UTC, Piotr
no flags Details
File: ifcfg.log (14.27 KB, text/plain)
2013-12-19 10:05 UTC, Piotr
no flags Details

Description Piotr 2013-12-19 10:04:13 UTC
Description of problem:
przy instalacji fedory wersji nowszej niż 14 wyskakuje mi ten błąd i nie mogę nic zrobić, płyta została nagrana poprawnie

Version-Release number of selected component:
anaconda-20.25.15-1.fc20.x86_64

The following was filed automatically by anaconda:
anaconda 20.25.15-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/encodings/utf_8.py", line 16, in decode
    return codecs.utf_8_decode(input, errors, True)
  File "/usr/lib64/python2.7/site-packages/gi/overrides/GLib.py", line 452, in markup_escape_text
    return GLib.markup_escape_text(text.decode('UTF-8'), length)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 259, in _updateCompleteness
    spoke.selector.set_tooltip_markup(GLib.markup_escape_text(spoke.status))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 212, in _createBox
    self._updateCompleteness(spoke)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 379, in refresh
    self._createBox()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/__init__.py", line 740, in _on_continue_clicked
    nextAction.refresh()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 68, in _on_continue_clicked
    cb()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/welcome.py", line 317, in _on_continue_clicked
    StandaloneSpoke._on_continue_clicked(self, cb)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/__init__.py", line 72, in <lambda>
    self.window.connect("continue-clicked", lambda *args: self._on_continue_clicked(cb))
UnicodeDecodeError: 'utf8' codec can't decode byte 0xaf in position 28: invalid start byte

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-base
cmdline_file:   BOOT_IMAGE=/isolinux/vmlinuz0 root=live:LABEL=Fedora-Live-Desktop-x86_64-20-1 ro rd.live.image quiet rhgb
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.10-301.fc20.x86_64
other involved packages: pygobject3-base-3.10.2-1.fc20.x86_64, python-libs-2.7.5-9.fc20.x86_64
product:        Fedora
release:        Fedora release 20 (Heisenbug)
type:           anaconda
version:        20

Comment 1 Piotr 2013-12-19 10:04:27 UTC
Created attachment 838905 [details]
File: anaconda-tb

Comment 2 Piotr 2013-12-19 10:04:30 UTC
Created attachment 838906 [details]
File: anaconda.log

Comment 3 Piotr 2013-12-19 10:04:32 UTC
Created attachment 838907 [details]
File: environ

Comment 4 Piotr 2013-12-19 10:04:39 UTC
Created attachment 838908 [details]
File: journalctl

Comment 5 Piotr 2013-12-19 10:04:41 UTC
Created attachment 838909 [details]
File: lsblk_output

Comment 6 Piotr 2013-12-19 10:04:43 UTC
Created attachment 838910 [details]
File: nmcli_dev_list

Comment 7 Piotr 2013-12-19 10:04:50 UTC
Created attachment 838911 [details]
File: os_info

Comment 8 Piotr 2013-12-19 10:04:54 UTC
Created attachment 838912 [details]
File: program.log

Comment 9 Piotr 2013-12-19 10:05:02 UTC
Created attachment 838913 [details]
File: storage.log

Comment 10 Piotr 2013-12-19 10:05:05 UTC
Created attachment 838914 [details]
File: ifcfg.log

Comment 11 David Shea 2013-12-19 16:05:19 UTC
Can you provide steps to reproduce this error? Which install media did you use?

From the log files you attached, the error appears to occur while displaying a message about the wireless access point. I attempted to install in Polish on a system with wifi connected using the Desktop Live CD, and everything seemed to work fine.

Comment 12 David Shea 2014-01-23 21:12:00 UTC
There's been no response for over a month, closing


Note You need to log in before you can comment on or make changes to this bug.