Bug 1044972 - Missing [OK] [Failed] msg in startup
Summary: Missing [OK] [Failed] msg in startup
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: systemd-maint
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: systemd-RFE
TreeView+ depends on / blocked
 
Reported: 2013-12-19 10:54 UTC by Jóhann B. Guðmundsson
Modified: 2014-01-23 13:51 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-23 13:51:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Jóhann B. Guðmundsson 2013-12-19 10:54:43 UTC
Description of problem:

Got asked/pointed at this by coworker who was looking at bootup image of [1] that there where no [OK] Status for the mountpoints as well as misleading [OK] messages for example

"Starting Recreate Volatile Files and Directories..." shows no OK MSG ( should this line be displayed as in Starting line? ).

Then later

[  OK  ] Started Recreate Volatile Files and Directories.

etc. 

I guess it basically just boils down to showing just lines like Started ( not Starting ) Mounted ( Not mounting ) etc in the bootup with OK/Failed but leave "Starting" for debug output.

Make sense?

1. http://www.freedesktop.org/wiki/Software/systemd/#relatedpackages

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Lennart Poettering 2014-01-23 13:51:08 UTC
Hmm, wut?

We can only sanely append output to the end of the screen, since terminals suck and we don't want to do full ncurses and then have two codepaths for smart and for dumb terminals.

Because of that we will print one line when we start doing things, without and  "[ ok ]" or "[ failed ]" on it. After all, it's just starting to do that step, so we don't have any ultimate success/failure information about it. Then, later, when the job finished, we will print the second line, this time with that "[ ok ]" or "[ failed ]" prefixed.

Having both lines is highly relevant, so that the admin can identify what the system waits for, and also what the result of the jobs are. 

So, I'd argue that the output is as good as it gets, given that we only can add output to the end of the screen, and we always need to show both information about the beginning and the end of a job.

Closing.


Note You need to log in before you can comment on or make changes to this bug.