Bug 1044993 - [engine-setup] when path to log is dir, engine-setup silently fails
Summary: [engine-setup] when path to log is dir, engine-setup silently fails
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: otopi
Classification: oVirt
Component: Plugins.core
Version: 1.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium vote
Target Milestone: ---
: 1.2.0
Assignee: Yedidyah Bar David
QA Contact: yeylon@redhat.com
URL:
Whiteboard: integration
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-19 11:58 UTC by Jiri Belka
Modified: 2015-09-20 21:04 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-20 13:38:56 UTC
oVirt Team: ---
alonbl: devel_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 22625 None None None Never

Description Jiri Belka 2013-12-19 11:58:31 UTC
Description of problem:


# mkdir /foobar
# engine-setup --log=/foobar ; echo $?
1

Version-Release number of selected component (if applicable):
is27

How reproducible:
100%

Steps to Reproduce:
1. mkdir /foobar
2. engine-setup --log=/foobar
3.

Actual results:
silently fails

Expected results:
?? maybe tell me the log path is dir and not file

Additional info:

Comment 1 Alon Bar-Lev 2013-12-19 15:57:03 UTC
right, the failure is in too early stage, at this stage we do not have dialog, too fundamental.

OTOPI_DEBUG=1 ... will reveal it.

Comment 2 Yedidyah Bar David 2013-12-29 08:32:39 UTC
Changed target to 3.4.0 because a good solution turns out to be not that simple and I think it's not that urgent. Note alon's comment #1 for a workaround.

Comment 3 Alon Bar-Lev 2013-12-29 12:31:33 UTC
I cannot remove  	rhevm-3.3.z

Comment 5 Alon Bar-Lev 2014-01-13 11:44:00 UTC
 Sandro Bonazzola 2014-01-13 05:08:49 EST
Target Release: 3.4.0 → 3.3.1
Flags: rhevm-3.3.z?

sandro, this is not important enough for z-stream.

Comment 6 Sandro Bonazzola 2014-01-14 07:17:43 UTC
(In reply to Alon Bar-Lev from comment #5)
>  Sandro Bonazzola 2014-01-13 05:08:49 EST
> Target Release: 3.4.0 → 3.3.1
> Flags: rhevm-3.3.z?
> 
> sandro, this is not important enough for z-stream.

ok

Comment 7 Shai Revivo 2014-02-20 13:38:56 UTC
This bug was fixed and is slated to be in the upcoming version. As we are focusing our testing at this phase on severe bugs, this bug was closed without going through its verification step. If you think this bug should be verified by QE, please set its severity to high and move it back to ON_QA


Note You need to log in before you can comment on or make changes to this bug.