Bug 1045039 - RFE: qemu: Provide a per-VM way to not have libvirt strip emulator capabilities
Summary: RFE: qemu: Provide a per-VM way to not have libvirt strip emulator capabilities
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
: 1043249 (view as bug list)
Depends On: 1043249
Blocks: TRACKER-bugs-affecting-libguestfs
TreeView+ depends on / blocked
 
Reported: 2013-12-19 13:57 UTC by Richard W.M. Jones
Modified: 2019-12-12 17:30 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1043249
Environment:
Last Closed: 2019-12-12 17:30:10 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2013-12-19 13:57:25 UTC
+++ This bug was initially created as a clone of Bug #1043249 +++

See:
https://bugzilla.redhat.com/show_bug.cgi?id=1043249#c6
https://bugzilla.redhat.com/show_bug.cgi?id=1043249#c7
https://bugzilla.redhat.com/show_bug.cgi?id=1043249#c9
https://bugzilla.redhat.com/show_bug.cgi?id=1043249#c10

Provide a way for libvirt to run qemu as is, without
modifying capabilities (or anything else).

Comment 1 Cole Robinson 2016-04-19 17:45:31 UTC
*** Bug 1043249 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Berrangé 2019-11-28 13:04:53 UTC
Suggestion to just stop clearing capabilities entirely

https://www.redhat.com/archives/libvir-list/2019-November/msg01429.html

Comment 3 Daniel Berrangé 2019-12-12 17:30:10 UTC
commit 1902356231cbca6db733748051ec0aa4bd208c48
Author: Daniel P. Berrangé <berrange@redhat.com>
Date:   Thu Nov 28 14:27:54 2019 +0000

    qemu: keep capabilities when running QEMU as root


Note You need to log in before you can comment on or make changes to this bug.