Bug 1045078 - [rfe] repoquery
[rfe] repoquery
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf-plugins-core (Show other bugs)
20
All Linux
low Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-19 09:57 EST by Michael Monreal
Modified: 2014-09-30 19:41 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.1.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-17 19:26:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Monreal 2013-12-19 09:57:59 EST
One thing I am missing from dnf atm is the ability to list files installed by a package, the way "repoquery --list $package" does.
Comment 1 Ales Kozumplik 2013-12-20 02:07:43 EST
Hello, thanks for the report. Since we haven't yet started to provide repoquery at all yet I'll change this bug to general repoquery RFE.
Comment 2 Panu Matilainen 2013-12-20 06:15:24 EST
Might be a good chance to sanitize things as well by having dnf/hawkey provide some of the things repoquery needs to avoid having to wrap every single package object within another one within repoquery. Doesn't matter when you're querying a handful of packages, but for queries of thousands of packages its slow and causes memory-use to blow through the roof :) I dont remember the details offhand though, been a while I've looked at repoquery...
Comment 3 Michael Monreal 2013-12-20 08:07:45 EST
I don't know what exactly is planned here, will this also include the ability to list buildrequires for a package such as possible with "yum-builddep"? That would be the final thing I currently miss in dnf.
Comment 4 Ales Kozumplik 2013-12-20 09:37:23 EST
builddeps are planned, but not as a part of this bug. check out the bug 905697.
Comment 5 Ales Kozumplik 2014-05-15 04:53:41 EDT
Looks like Tim has already started on this:

https://github.com/timlau/dnf-utils/blob/master/plugins/query.py

Let's start from merging this int plugins-core and taking it from there.
Comment 6 Ales Kozumplik 2014-05-29 10:54:35 EDT
Repoquery has been added as a plugin command by 4524d56 and other patches upstream.
Comment 7 Fedora Update System 2014-06-04 09:19:09 EDT
dnf-plugins-core-0.1.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.0-1.fc20
Comment 8 Michael Monreal 2014-06-04 14:31:46 EDT
(In reply to Fedora Update System from comment #7)
> dnf-plugins-core-0.1.0-1.fc20 has been submitted as an update for Fedora 20.
> https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.0-1.fc20

Seems like it was not included in this build?
Comment 9 Fedora Update System 2014-06-05 00:21:26 EDT
Package dnf-plugins-core-0.1.0-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.1.0-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-7072/dnf-plugins-core-0.1.0-1.fc20
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2014-06-05 03:16:44 EDT
dnf-plugins-core-0.1.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-plugins-core-0.1.0-2.fc20
Comment 11 Michael Monreal 2014-06-05 12:27:00 EDT
(In reply to Fedora Update System from comment #10)
> dnf-plugins-core-0.1.0-2.fc20 

This seems to work now, however the functionality I was looking for ("repoquery --list $package" as mentioned in the initial post) is not implemented.
Comment 12 Petr Spacek 2014-06-17 10:35:56 EDT
I think that DNF is a good chance to make "rpm -q" and "repoquery" compatible.

It would be nice to use the same exit codes as RPM.
$ rpm -q --whatprovides blahblah
returns 1 instead of 0
Comment 13 Fedora Update System 2014-06-17 19:26:48 EDT
dnf-plugins-core-0.1.0-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.