Bug 1045116 - weird symlink in dev
Summary: weird symlink in dev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1047068 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-19 16:02 UTC by Dave Jones
Modified: 2015-01-04 22:32 UTC (History)
14 users (show)

Fixed In Version: dracut-037-10.git20140402.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-06 02:37:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Dave Jones 2013-12-19 16:02:14 UTC
rkhunter notified me about this weird symlink in /dev

lrwxrwxrwx. 1 root root 10 Dec 18 13:55 /dev/dev/resume -> ../../sda2

I'm not sure what creates it, as its unowned, so I'm starting with dracut.

Comment 2 Harald Hoyer 2014-01-09 08:59:37 UTC
*** Bug 1047068 has been marked as a duplicate of this bug. ***

Comment 3 g. artim 2014-01-20 01:41:08 UTC
got same error after apply patch to /modules.d/95resume/parse-resume.sh,
rebooted:

[gartim@genepi2 ~]$ ls -la  /dev/dev/resume 
lrwxrwxrwx 1 root root 10 Jan 19 17:32 /dev/dev/resume -> ../../vda3

no ../../vda3 exist, rkhunter is giving me a false position (me hope) the GasKit Rootkit warning.

Comment 4 John Horne 2014-01-21 22:20:29 UTC
Agreed. Applying the git patch made no difference at all. The broken link is still there.

Comment 5 Harald Hoyer 2014-01-22 10:13:20 UTC
(In reply to John Horne from comment #4)
> Agreed. Applying the git patch made no difference at all. The broken link is
> still there.

did you run:

# dracut -f

afterwards?

Comment 6 John Horne 2014-01-22 11:42:28 UTC
No... but I have now, and the link (and /dev/dev directory) have gone.

Thanks for that.

Comment 7 g. artim 2014-01-22 18:07:39 UTC
yep!! worked perfectly after
 dracut -f
 systemctl reboot
thanks much!

Comment 8 Didier G 2014-03-16 15:43:02 UTC
Looking for rkhunter bug and /dev/dev/resume I find this entry.

At this time, new dracut rpm dracut-034-80.git20140122.fc20 is available on koji but it seens this package has not be pushed on testing or update...

Comment 9 Didier G 2014-03-16 15:52:08 UTC
I updated to dracut-034-80.git20140122.fc20.x86_64 from koji

I also updated dracut-config-rescue and dracut-network for constitency.

Then I run dracut -f and rebooted.

This fixed rkhunter problem.

Comment 10 Fedora Update System 2014-04-02 08:56:58 UTC
dracut-037-10.git20140402.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-037-10.git20140402.fc20

Comment 11 Fedora Update System 2014-04-03 04:03:16 UTC
Package dracut-037-10.git20140402.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-037-10.git20140402.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4704/dracut-037-10.git20140402.fc20
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2014-04-06 02:37:11 UTC
dracut-037-10.git20140402.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.