Bug 1045182 - Upgrade to Fedora20 freezes, when selinux-policy-targeted not installed
Upgrade to Fedora20 freezes, when selinux-policy-targeted not installed
Status: CLOSED DUPLICATE of bug 1046191
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-19 14:49 EST by Tomas Lestach
Modified: 2014-01-08 13:02 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 13:02:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2013-12-19 14:49:54 EST
Description of problem:
On one of my computer I have selinux disabled and selinux-policy-targeted package uninstalled. When I tried to upgrade F19 to F20 using fedup, the tool freezes.
Last message displayed:
systemd[1]: failed to initialize selinux context: no such file or directory

Version-Release number of selected component (if applicable):
latest fedup in Fedora19

How reproducible:
always

Steps to Reproduce:
1. disable selinux on Fedora19 and uninstall selinux-policy-targeted package
2. install fedup and try to upgrade using --network option to Fedora20

Actual results:
Fedup pre-downloads all the packages and after restart it freezes with:
systemd[1]: failed to initialize selinux context: no such file or directory

Expected results:
Successful upgrade to Fedora20
Comment 1 Aaron Dotter 2013-12-25 04:50:18 EST
I submitted a bug report recently because I experience the same problem reported here despite the fact that, on my system, selinux-policy-targeted is installed.

https://bugzilla.redhat.com/show_bug.cgi?id=1046191
Comment 2 Will Woods 2014-01-07 15:03:20 EST
Does your system have SELinux disabled?
Comment 3 Tomas Lestach 2014-01-08 02:47:57 EST
(In reply to Will Woods from comment #2)
> Does your system have SELinux disabled?

Yes, it does.
Comment 4 Will Woods 2014-01-08 13:02:08 EST
Then this is the same root cause as bug 1046191.

*** This bug has been marked as a duplicate of bug 1046191 ***

Note You need to log in before you can comment on or make changes to this bug.