Bug 104519 - mkinitrd does not include all mptscsih dependencies
Summary: mkinitrd does not include all mptscsih dependencies
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mkinitrd (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-16 17:20 UTC by Eric Sandeen
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-29 22:48:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Sandeen 2003-09-16 17:20:43 UTC
Description of problem:
/sbin/mkinitrd does not make proper initrds for the LSI "mptscsih" driver

Version-Release number of selected component (if applicable):
mkinitrd-3.3.10-1
Also checked in Rawhide

How reproducible:
Every time

Steps to Reproduce:
1. Add "alias scsi_hostadapter mptscsih" to modules.conf
2. Make an initrd with -v
3. notice that mptscsih is added, but mptbase is not
4. notice that in modules.dep, mptbase is required by mptscsih:

/lib/modules/2.4.20-20.7.sgi1smp/kernel/drivers/message/fusion/mptscsih.o:
/lib/modules/2.4.20-20.7.sgi1smp/kernel/drivers/message/fusion/mptbase.o \
        /lib/modules/2.4.20-20.7.sgi1smp/kernel/drivers/scsi/scsi_mod.o

5. reboot box with this initrd
    
Actual results:
mptscsih driver is not loaded from initrd due to missing dependencies

Expected results:
mptscsih properly loaded

Additional info:
The following patch also removes requirements on xfs modules that have not 
existed for well over a year.

--- /sbin/mkinitrd.orig Tue Sep 16 11:54:56 2003
+++ /sbin/mkinitrd      Tue Sep 16 11:58:06 2003
@@ -88,18 +88,17 @@
        modName="ext3"
     fi
  
-    if [ "$modName" = "xfs" ]; then
-       findmodule $skiperrors pagebuf
-       findmodule $skiperrors xfs_support
-       modName="xfs"
-    fi
-
     if [ "$modName" = "ppa" ]; then
        findmodule parport
        findmodule parport_pc
        modName="ppa"
     fi
  
+    if [ "$modName" = "mptscsih" ]; then
+       findmodule mptbase
+       modName="mptscsih"
+    fi
+
     fmPath=`(cd /lib/modules/$kernel; echo find . -name $modName.o | /sbin/nash
--quiet)`
  
     if [ ! -f /lib/modules/$kernel/$fmPath ]; then

Comment 1 Jeremy Katz 2003-09-29 22:48:20 UTC
rawhide already has (equivalent) changes. 


Note You need to log in before you can comment on or make changes to this bug.