Bug 1045220 - Pulling the "ubuntu" image from upstream fails
Summary: Pulling the "ubuntu" image from upstream fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: docker-io
Version: el6
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Lokesh Mandvekar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-19 21:58 UTC by Don Marti
Modified: 2014-07-01 22:59 UTC (History)
7 users (show)

Fixed In Version: docker-io-0.7.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-03 22:43:42 UTC
Type: Bug


Attachments (Terms of Use)

Description Don Marti 2013-12-19 21:58:16 UTC
Description of problem:
Pulling the "ubuntu" Docker image from a remote repository fails if package xz-lzma-compat is not installed.

Version-Release number of selected component (if applicable):
0.7.0-14.el6.x86_64

How reproducible:


Steps to Reproduce:
1. Do a "docker run" command with the upstream "ubuntu" image not present locally.

Actual results:
$ docker run ubuntu echo "hello world"
Unable to find image 'ubuntu' (tag: latest) locally
Pulling repository ubuntu
8dbd9e392a96: Error pulling image (precise) from ubuntu, endpoint: https://cdn-registry-1.docker.io/v1/, exit status 2: tar (grandchild): xz: Cannot exec: No such file or directory
tar (grandchild): Error is not recoverable: exiting now



Expected results:
Docker pulls the "ubuntu" image, then "hello world" echoes from within the container.

Additional info:
This works fine as soon as xz-lzma-compat is installed using Yum.

Comment 1 Lokesh Mandvekar 2013-12-19 22:26:04 UTC
Hi Don,

looks like it's xz that the ubuntu image depends on, cause it seemed to work fine even after removing xz-lzma-compat, but I could see this error only after removing xz. Could you verify this please? I'll update the rpm once confirmed.

Comment 2 Don Marti 2013-12-19 23:46:02 UTC
Hi Lokesh,

Yes, you are right. I removed xz-lzma-compat and it works:

[demo@CentoOS6-2013-09-30 ~]$ docker run ubuntu echo "hello world"
Unable to find image 'ubuntu' (tag: latest) locally
Pulling repository ubuntu
8dbd9e392a96: Download complete
b750fe79269d: Download complete
27cf78414709: Download complete
hello world
[demo@CentoOS6-2013-09-30 ~]$ rpm -q xz
xz-4.999.9-0.3.beta.20091007git.el6.x86_64
[demo@CentoOS6-2013-09-30 ~]$ rpm -q xz-lzma-compat
package xz-lzma-compat is not installed

Thank you for your help.

Comment 3 Fedora Update System 2013-12-20 00:55:10 UTC
docker-io-0.7.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/docker-io-0.7.2-2.fc20

Comment 4 Fedora Update System 2013-12-20 01:03:16 UTC
docker-io-0.7.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/docker-io-0.7.2-2.fc19

Comment 5 Fedora Update System 2013-12-20 01:10:34 UTC
docker-io-0.7.2-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/docker-io-0.7.2-2.el6

Comment 6 Fedora Update System 2013-12-20 16:53:41 UTC
Package docker-io-0.7.2-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing docker-io-0.7.2-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-12437/docker-io-0.7.2-2.el6
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-01-03 22:43:42 UTC
docker-io-0.7.2-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2014-01-04 19:52:15 UTC
docker-io-0.7.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2014-01-04 19:54:20 UTC
docker-io-0.7.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.