Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1045314 - Imports added to import.suggestions are not shown in editors
Summary: Imports added to import.suggestions are not shown in editors
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: CR1
: 6.0.0
Assignee: Toni Rikkola
QA Contact: Jiri Locker
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-20 06:50 UTC by Toni Rikkola
Modified: 2014-08-06 20:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:16:18 UTC
Type: Bug


Attachments (Terms of Use)

Description Toni Rikkola 2013-12-20 06:50:56 UTC
Steps to Reproduce:
1. Add new import to project import suggestions
2. Try to use the import in the editors

Actual results:
Imports do not show up

Expected results:
Import should show up

Additional info:
Workaround is to for example save one of the following file types:
.java
.class
pom.xml
kmodule.xml
.drl
.gdst
.rdrl

Comment 2 Toni Rikkola 2013-12-20 07:02:07 UTC
master: https://github.com/droolsjbpm/guvnor/commit/3f0e99617

I also added support for rdslr and templates. Since changes in these should also fire a rebuild.

Comment 3 Walter Medvedeo 2014-01-09 20:53:51 UTC
First of all: 

I believe that the following commit should also be cherry-picked to 6.0.x branch:

https://github.com/droolsjbpm/guvnor/commit/ce171b863ab294e9fedab75813b762368b012674


Then:

This two additional commits related to this issue will resolve the problem of import suggestions refresh in the data modeller. (no longer server restart is needed)
 

guvnor project: 
    URL: http://github.com/droolsjbpm/guvnor/commit/7954edae8

kie-wb-common project:
    URL: http://github.com/droolsjbpm/kie-wb-common/commit/0daaac8e6

If we want to have a separate BZ for the import suggestions refresh problem, this two commits can be moved to a new BZ.
Plese confirm this with Rikkola.

Comment 5 Toni Rikkola 2014-01-10 08:18:44 UTC
(In reply to Toni Rikkola from comment #4)
> Sure, both
> https://github.com/droolsjbpm/guvnor/commit/3f0e99617
> and
> https://github.com/droolsjbpm/guvnor/commit/
> ce171b863ab294e9fedab75813b762368b012674
> can be cherry-picked to 6.0.x

Once this is a blocker+ and this should be.


Note You need to log in before you can comment on or make changes to this bug.