Bug 104532 - ulimit -t does not work correctly
ulimit -t does not work correctly
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Geoff Gustafson
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-16 16:08 EDT by Joe Polcari
Modified: 2007-11-30 17:06 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-03 21:24:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
abi friendly version of the patch (3.17 KB, text/plain)
2004-05-28 15:05 EDT, Jason Baron
no flags Details

  None (edit)
Description Joe Polcari 2003-09-16 16:08:45 EDT
Description of problem:

ulimit -t 500 will kill the current shell at the next command.

Version-Release number of selected component (if applicable):
?

How reproducible:

use ulimit -t

Steps to Reproduce:
1.ulimit -t 500 will kill the current shell at the next command.
ulimit -t reports incorrect values after using a high enough number
that it doesn't kill the currect shell.
    
Actual results:

[root@nht7400 etc]# bash -l
[root@nht7400 etc]# ulimit -t 999999999
[root@nht7400 etc]# ps
Killed
[root@nht7400 etc]# bash -l
[root@nht7400 root]# ulimit -t 120
Killed
[root@nht7400 root]# ulimit -t 9999999999999999999
[root@nht7400 root]# ulimit -t
9999999999999999999
[root@nht7400 root]# ulimit -t 99999999999999999999
[root@nht7400 root]# ulimit -t
7766279631452241919
[root@nht7400 root]# 

Expected results:
not killed. ulimit -t should represent what was set.

Additional info:
[root@nht7400 root]# uname -a
Linux nht7400 2.4.21-1.1931.2.399.ent #1 SMP Wed Aug 20 15:23:44 EDT 2003 ia64 
ia64 ia64 GNU/Linux
[root@nht7400 root]# cat /etc/redhat-release 
Red Hat Enterprise Linux release 2.9.5AS (Taroon)

What else do you need to know?
Comment 1 Joe Polcari 2003-09-16 16:14:03 EDT
This does not appear to related to bash since I also tried bash from 7.1
which is bash 2.04.21.
Comment 2 Ingo Molnar 2003-09-17 04:48:07 EDT
I tried this on a recent kernel and ulimit -t works as expected.

Could you please upgrade to a newer taroon kernel via RHN, and re-check?
Comment 3 Ingo Molnar 2003-09-17 04:50:11 EDT
actually - i only checked on x86 - ia64 might have a 64-bitness bug here.
Comment 4 Joe Polcari 2003-09-17 10:23:19 EDT
which is it, are you going to test 64 bit as I have reported it on 64 bit or
should I upgrade the kernel?
Comment 5 Larry Woodman 2003-09-17 11:17:39 EDT
I tested this out on ia64 running the release candidate kernel and
I think the kernel is working correctly.  I am not getting any kills
at all and if I use the setrlimit system call everything seems to work
fine.  However, I do suspect that there is something amiss with the 
builtin ulimit command because it doesnt show what is entered and
doesnt show up as unlimited when you exceed 20 decimal digits.

Larry
Comment 6 Joe Polcari 2003-09-17 11:32:48 EDT
1. What version is the release candidate
2. I tried this using bash from a 7.1 build,
     [root@nht6003 /root]# bash --version
     GNU bash, version 2.04.21(1)-release (ia64-redhat-linux-gnu)
     Copyright 1999 Free Software Foundation, Inc.
     [root@nht6003 /root]#
and it has the same problem on any of my EL3b2 systems which is why I 
did not think it was the built-in.
My kernels are 2.4.21-1.1931.2.399.ent #1 SMP Wed Aug 20 15:23:44 EDT 2003 ia64 
ia64 ia64 GNU/Linux
Comment 7 Jason Baron 2004-05-28 15:02:12 EDT
is this still an issue?
Comment 8 Jason Baron 2004-05-28 15:05:27 EDT
Created attachment 100677 [details]
abi friendly version of the patch
Comment 9 Jason Baron 2004-05-28 15:06:11 EDT
oops attached this to the wrong bug :(. Please ignore my last comment
Comment 10 Ernie Petrides 2005-10-03 21:24:30 EDT
Closing due to lack of response to comment #7.

Note You need to log in before you can comment on or make changes to this bug.