Bug 1045374 - 'gluster volume status --xml' has issues
Summary: 'gluster volume status --xml' has issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs
Version: 2.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: RHGS 2.1.2
Assignee: Kaushal
QA Contact: Shruti Sampat
URL:
Whiteboard:
Depends On: 1046020
Blocks: 1021441
TreeView+ depends on / blocked
 
Reported: 2013-12-20 09:50 UTC by Shruti Sampat
Modified: 2015-05-13 16:33 UTC (History)
8 users (show)

Fixed In Version: glusterfs-3.4.0.53rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1046020 (view as bug list)
Environment:
Last Closed: 2014-02-25 08:09:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0208 0 normal SHIPPED_LIVE Red Hat Storage 2.1 enhancement and bug fix update #2 2014-02-25 12:20:30 UTC

Description Shruti Sampat 2013-12-20 09:50:07 UTC
Description of problem:
-------------------------

The following is from the output of "gluster volume status --xml" command - 

-------
          <node>
             <node>
               <hostname>NFS Server</hostname>
               <path>localhost</path>
<peerid>63ca3d2f-8c1f-4b84-b797-b4baddab81fb</peerid>
               <status>1</status>
               <port>2049</port>
               <pid>2130</pid>
             </node>
-----

The xml tag <node> is nested as seen above.

Version-Release number of selected component (if applicable):
glusterfs 3.4.0.50rhs

How reproducible:
Always

Steps to Reproduce:
1. Run the "gluster volume status --xml" command for a distributed-replicate volume.

Actual results:
The <node> tag is nested as seen above.

Expected results:
<node> tag should not be nested.

Additional info:

Comment 4 Shruti Sampat 2014-01-03 06:37:36 UTC
Verified as fixed in glusterfs-3.4.0.53rhs.

Comment 6 errata-xmlrpc 2014-02-25 08:09:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html


Note You need to log in before you can comment on or make changes to this bug.