This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 1045463 - processing instructions contained in PO files are incorrectly stripped
processing instructions contained in PO files are incorrectly stripped
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.2
Unspecified Unspecified
unspecified Severity unspecified
: 4.1
: ---
Assigned To: Jeff Fearn
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-12-20 08:50 EST by Raphaël Hertzog
Modified: 2014-05-05 02:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: 4.1.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-05 02:03:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Possible patch (499 bytes, patch)
2013-12-20 09:26 EST, Raphaël Hertzog
no flags Details | Diff

  None (edit)
Description Raphaël Hertzog 2013-12-20 08:50:18 EST
This is very much like https://bugzilla.redhat.com/show_bug.cgi?id=819420 except that it concerns translations instead of the original document.

Description: When I add some processing instructions in some translated strings (i.e. in a msgid in a PO file), it doesn't get carried over to the generated XML files. The processing instruction is neither present in the tmp/<lang>/xml/* files nor in the tmp/<lang>/xml_tmp/* files (so it's lost even earlier than #819420 IIRC).

Expected result: The processing instructions should be kept.
Comment 1 Raphaël Hertzog 2013-12-20 09:26:11 EST
Created attachment 839576 [details]
Possible patch

This patch works for me. But maybe the better fix is to enhance Publican::new_tree() to always call $xml_doc->store_pis(1) given that I don't see any place where we really want to drop processing instructions.
Comment 2 Jeff Fearn 2014-01-05 19:07:03 EST
Hey Rudi, do we want to allow translators to set processing instructions?
Comment 3 Ruediger Landmann 2014-02-25 00:12:53 EST
Sure!
Comment 4 Jeff Fearn 2014-03-03 17:53:14 EST
Added store_pis call to Publican::new_tree().

To ssh://git.fedorahosted.org/git/publican.git
   8cf3d60..62b41f3  devel -> devel
Comment 5 Jeff Fearn 2014-05-05 02:03:29 EDT
A fix for this shipped in Publican 4.1.0.

Note You need to log in before you can comment on or make changes to this bug.