Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1045473 - Debug messages are not displayed by the client
Summary: Debug messages are not displayed by the client
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: oc
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-20 14:23 UTC by Jorge Aguilar
Modified: 2015-05-15 02:26 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-30 00:54:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jorge Aguilar 2013-12-20 14:23:21 UTC
Description of problem:

I got "503 Service Unavailable No server is available to handle this request." when I try http://tengofutbol-softevo.rhcloud.com



Version-Release number of selected component (if applicable):

$ rhc app show
tengofutbol @ http://tengofutbol-softevo.rhcloud.com/ (uuid: 51897bb1500446841a000501)
--------------------------------------------------------------------------------------
  Created: May 07  5:09 PM
  Gears:   2 (defaults to small)
  Git URL: ssh://51897bb1500446841a000501@tengofutbol-softevo.rhcloud.com/~/git/tengofutbol.git/
  SSH:     51897bb1500446841a000501@tengofutbol-softevo.rhcloud.com
  Aliases: www.tengofutbol.com, hoy.tengofutbol.com

  ruby-1.9 (Ruby 1.9)
  -------------------
    Scaling: x1 (minimum: 1, maximum: available) on small gears

  haproxy-1.4 (Web Load Balancer)
  -------------------------------
    Gears: Located with ruby-1.9

  postgresql-9.2 (PostgreSQL 9.2)
  -------------------------------
    Gears:          1 small
    Connection URL: postgresql://$OPENSHIFT_POSTGRESQL_DB_HOST:$OPENSHIFT_POSTGRESQL_DB_PORT
    Database Name:  tengofutbol


How reproducible:

Steps to Reproduce:
1. $ rhc app force-stop
2. $ rhc app start

Actual results:

Unable to complete the requested operation due to: Failed to correctly execute all parallel operations - ["StartCompOp"].

Expected results:

My working page


Additional info:

$ rhc app start -d
DEBUG: Authenticating with RHC::Auth::Token
DEBUG: Connecting to https://openshift.redhat.com/broker/rest/api
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/api
DEBUG:    code 200  623 ms
DEBUG: Request GET https://openshift.redhat.com/broker/rest/api
DEBUG:    code 200  509 ms
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains
DEBUG:    code 200  458 ms
DEBUG: Getting app context
DEBUG: Running git config --get rhc.app-name
DEBUG: UUID = 'tengofutbol'
DEBUG: Getting all domains
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/softevo/applications/tengofutbol
DEBUG:    code 200  263 ms
DEBUG: Starting application tengofutbol
DEBUG: Request POST https://openshift.redhat.com/broker/rest/domain/softevo/application/tengofutbol/events
DEBUG:    code 500 2198 ms
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations - ["StartCompOp"].
Reference ID: ac77dcf8e2c2f20c99d0ab017347429c

Comment 2 Abhishek Gupta 2013-12-20 22:08:25 UTC
It failed to write to the logs due to the disk quota being exhausted. If you upgrade to the latest rhc CLI tools, you will be able to see the warning below when you run into this situation.

Warning gear 51897bb1500446841a000501 is using 100.0% of disk quota

Comment 3 Abhishek Gupta 2013-12-20 22:19:49 UTC
Also, the CLI does not show the debug messages returned by the REST API. Based on a discussion with Clayton, maybe we can display the debug/warning messages under "Additional Info"

Comment 4 Jorge Aguilar 2013-12-22 15:18:25 UTC
Thanks Abhishek...

That was the problem! I folowed your suggestion and now the application is working.

What I did:

1) Update rhc

2) Check quota

rhc show-app <app> --gears quota

3) Clean logs and tmp files

rhc app tidy

It did not work because disk quota is 100%

4) Log in using ssh to empty (or remove) files (production.log in my case)

5) Execute tidy again

rhc app tidy

6) Start application

Comment 5 Fabiano Franz 2014-01-02 18:39:43 UTC
Fixed, please verify.

Comment 6 Wei Sun 2014-01-03 02:55:59 UTC
Verified on devenv_4177 with rhc 1.19.3

Result:
[root@ip-10-236-172-109 ~]# rhc app-start r9s -d
DEBUG: Using config file /root/.openshift/express.conf
DEBUG: Git config 'git config --get rhc.app-id' returned ''
DEBUG: Git config 'git config --get rhc.app-name' returned ''
DEBUG: Git config 'git config --get rhc.domain-name' returned ''
DEBUG: Authenticating with RHC::Auth::Token
DEBUG: Connecting to https://localhost/broker/rest/api
DEBUG: Getting all domains
DEBUG: Client supports API versions 1.1, 1.2, 1.3, 1.4, 1.5, 1.6
DEBUG: Using token authentication
DEBUG: Created new httpclient
DEBUG: Request GET https://localhost/broker/rest/api
DEBUG: SSL Verification failed -- Using self signed cert
DEBUG:    code 200   32 ms
DEBUG: Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5, 1.6
DEBUG:    Using API version 1.6
DEBUG: Client API version 1.6 is not current. Refetching API
DEBUG: Using token authentication
DEBUG: Request GET https://localhost/broker/rest/api
DEBUG:    code 200   16 ms
DEBUG: Using token authentication
DEBUG: Request GET https://localhost/broker/rest/domains
DEBUG:    code 200   99 ms
DEBUG: Using token authentication
DEBUG: Request GET https://localhost/broker/rest/domains/wsundev4177/applications/r9s
DEBUG:    code 200   39 ms
DEBUG: Starting application r9s
DEBUG: Using token authentication
DEBUG: Request POST https://localhost/broker/rest/application/52c6244bad1ecd43cc0000e2/events
DEBUG:    code 200 1195 ms
Warning: Gear 52c6244bad1ecd43cc0000e2 is using 100.0% of disk quota

RESULT:
r9s started


Note You need to log in before you can comment on or make changes to this bug.