Bug 104552 - redhat-config-kickstart writes invalid firstboot line.
redhat-config-kickstart writes invalid firstboot line.
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-kickstart (Show other bugs)
3.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-16 22:10 EDT by John Byrne
Modified: 2007-11-30 17:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-17 11:33:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Byrne 2003-09-16 22:10:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
redhat-config-kickstart writes the firstboot line as "firstboot --enabled";
anaconda-9.0.5-5.RHEL expects "--enable". Maybe this should actually be an
anaconda bug because "--enabled" is consistent with other usages.


Version-Release number of selected component (if applicable):
redhat-config-kickstart-2.3.15-2

How reproducible:
Always

Steps to Reproduce:
1. Launch redhat-config-kickstart.
2. Enter a root password to keep it happy.
3. Select "X Configuration" and enable Setup Agent
4. Select "Preview" under the "File" menu to view the result.
    

Actual Results:  From preview window

...snipped..
#Run the Setup Agent on first boot
firstboot --enabled
...snipped...

Expected Results:  ...snipped..
#Run the Setup Agent on first boot
firstboot --enable
...snipped...

Additional info:
Comment 1 Brent Fox 2003-09-17 11:33:26 EDT
Fixed in redhat-config-kickstart-2.3.19-1.  Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.