Bug 104560 - Adding the appointment doesn't work with localized time
Summary: Adding the appointment doesn't work with localized time
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: evolution   
(Show other bugs)
Version: 3.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-17 07:01 UTC by Akira TAGOH
Modified: 2007-11-30 22:06 UTC (History)
1 user (show)

Fixed In Version: 1.4.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-22 10:12:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backported patch (2.01 KB, patch)
2003-09-17 09:21 UTC, Akira TAGOH
no flags Details | Diff

Description Akira TAGOH 2003-09-17 07:01:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030303

Description of problem:
I just tried to add the appointment with specified time, but I can't add it.
Evolution said, "Start time is wrong" or "End time is wrong". it's always failed
with CJK locale. it looks like the parser can't understands the localized time.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run evolution with ja_JP locale.
2.go to Calendar, choose New->Appointment
3.specify the date and the time, save it then
    

Actual Results:  the error occurs like "Start time is wrong" or "End time is wrong"

Expected Results:  save the appointment correctly

Additional info:

Comment 1 Akira TAGOH 2003-09-17 07:10:00 UTC
Pointer to the upstream bugzilla - http://bugzilla.ximian.com/show_bug.cgi?id=45278
It seems that it was already filed, but no reply.

Comment 2 Akira TAGOH 2003-09-17 09:21:26 UTC
Created attachment 94550 [details]
backported patch

This issue seems to be fixed in CVS:
2003-08-20  Suresh Chandrasekharan <suresh.chandrasekharan@sun.com>

	*  e-time-utils.c (parse_with_strptime): Fixes #43558 Appointment
	Editor always gives time validation error for apptmnts in non
	UTF-8/non ASCII locales.

Could you apply this backported patch for us?

Comment 3 Jeremy Katz 2003-09-19 22:45:32 UTC
The patch is in 1.4.5 which is built and in -scratch, just pending some testing
before being moved over.

Comment 4 Akira TAGOH 2003-09-22 08:59:37 UTC
Ok. I have confirmed the fix in 1.4.5.

Comment 5 Akira TAGOH 2004-01-22 10:12:14 UTC
Taroon had 1.4.5. so closing.


Note You need to log in before you can comment on or make changes to this bug.