Bug 1045682 - SELinux preventing dhclient from reading libk5crypto.so.3 resulting in no addresses received/assigned
SELinux preventing dhclient from reading libk5crypto.so.3 resulting in no add...
Status: CLOSED DUPLICATE of bug 1045699
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
rawhide
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Jiri Popelka
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F21AlphaBlocker
  Show dependency treegraph
 
Reported: 2013-12-21 01:47 EST by Dan Mossor [danofsatx]
Modified: 2014-01-02 16:53 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-02 16:53:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
messages log containing error on restart of NetworkManager (10.06 KB, text/plain)
2013-12-21 01:47 EST, Dan Mossor [danofsatx]
no flags Details
journal output showing execstack and execmem denials for dhclient (6.57 KB, text/plain)
2013-12-23 12:36 EST, Adam Williamson
no flags Details

  None (edit)
Description Dan Mossor [danofsatx] 2013-12-21 01:47:47 EST
Created attachment 839925 [details]
messages log containing error on restart of NetworkManager

Description of problem: 

 No IPv4 addresses are being assigned via DHCP to the network interfaces.

Version-Release number of selected component (if applicable):

 dhclient-4.2.5-28.fc21.x86_64
 NetworkManager-0.9.9.0-19.git20131003.fc21.x86_64

How reproducible:

 Every time.

Steps to Reproduce:
1. Activate a network interface configured to receive an address via DHCP.
2. Wait patiently.
3. Discover that no IPv4 address was assigned.

Actual results:

 No IPv4 address assigned to interface, effectively blocking all network access (IPv6 was not tested due to other issues with IPv6 registration).

Expected results:

 IPv4 address assigned by the DHCP server, allowing system to communicate on the network.
Comment 1 Adam Williamson 2013-12-23 12:34:37 EST
This is an SELinux issue; check the journal for errors from auditctl. If you do 'setenforce Permissive' it works.
Comment 2 Adam Williamson 2013-12-23 12:36:58 EST
Created attachment 840912 [details]
journal output showing execstack and execmem denials for dhclient
Comment 3 satellitgo 2013-12-23 18:56:52 EST
setting selinux to permissive fixes the KDE networking problem (with sddm) in f21 (rawhide) a live install of latest koji
see also BZ 1045937
Comment 4 Dan Mossor [danofsatx] 2014-01-02 16:53:26 EST
Same base issue as bz 1045699 - marking as duplicate.

*** This bug has been marked as a duplicate of bug 1045699 ***

Note You need to log in before you can comment on or make changes to this bug.