Bug 1045709 - open-vm-tools should depend on which
Summary: open-vm-tools should depend on which
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: open-vm-tools
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ravindra Kumar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-21 11:24 UTC by Sitsofe Wheeler
Modified: 2014-04-15 15:43 UTC (History)
4 users (show)

Fixed In Version: open-vm-tools-9.4.0-8.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-11 20:48:37 UTC


Attachments (Terms of Use)

Description Sitsofe Wheeler 2013-12-21 11:24:51 UTC
Description of problem:
Scripts in /etc/vmware-tools/scripts/ make use of which but there's no RPM dependency on it.

Version-Release number of selected component (if applicable):
open-vm-tools-9.4.0-1.fc20.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. Download the Fedora 20 cloud image.
2. Use qemu-img to convert the image to a vmdk
qemu-img convert -O vmdk -o adapter_type=lsilogic Fedora-x86_64-20-20131211.1-sda.raw Fedora-x86_64-20-20131211.1-sda.vmdk
3. Attach the vmdk to a VM and boot it.
4. Set init to boot to bash, re-enable root and schedule an selinux relabel.
5. Run yum install open-vm-tools .
6. Run
systemctl enable vmtoolsd.service
and reboot the machine.
7. Look in the journal for errors.

Actual results:
Error messages about which not being available.

Expected results:
which to have been installed before open-vm-tools was installed.

Additional info:
Thanks for making open-vm-tools - it lets the system start so much faster than the regular VMWare tools and also doesn't break on kernel updates!

Comment 1 Sitsofe Wheeler 2013-12-21 11:25:55 UTC
Forgot to say:
$ grep -r which /etc/vmware-tools/scripts/
/etc/vmware-tools/scripts/vmware/network:# runs it with the given argument (which should be one of the usual SysV
/etc/vmware-tools/scripts/vmware/network:   service=`which service 2>/dev/null`
/etc/vmware-tools/scripts/vmware/network:   # `which' may be a bit noisy, so we'll shush it.
/etc/vmware-tools/scripts/vmware/network:   dbusSend=`which dbus-send 2>/dev/null`
/etc/vmware-tools/scripts/vmware/network:   # `which' may be a bit noisy, so we'll shush it.
/etc/vmware-tools/scripts/vmware/network:   dbusSend=`which dbus-send 2>/dev/null`
/etc/vmware-tools/scripts/vmware/network:   which ifup >/dev/null 2>&1      || Panic "ifup not in search path."
/etc/vmware-tools/scripts/vmware/network:   which ifconfig >/dev/null 2>&1  || Panic "ifconfig not in search path."

Comment 2 Ravindra Kumar 2014-01-17 23:58:53 UTC
There is also a dependency on coreutils because of 'date' and 'dirname' commands. I will add a dependency to 'which' and 'coreutils'.

Comment 3 Ravindra Kumar 2014-03-19 18:14:40 UTC
(In reply to Ravindra Kumar from comment #2)
> There is also a dependency on coreutils because of 'date' and 'dirname'
> commands. I will add a dependency to 'which' and 'coreutils'.

Here is the complete list of dependencies for the scripts included in the package:

- 'ifup' from 'initscripts' package
- 'ifconfig' from 'net-tools' package
- 'dbus-send' from 'dbus' package
- 'egrep' from 'grep' package
- 'expr/date/dirname' from 'coreutils' package
- 'sed' from 'sed' package
- 'printf/basename' from 'coreutils' package
- 'tar' from 'tar' package

Comment 4 Fedora Update System 2014-03-26 01:13:28 UTC
open-vm-tools-9.4.0-7.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/open-vm-tools-9.4.0-7.fc20

Comment 5 lnie 2014-03-26 02:57:18 UTC
open-vm-tools-9.4.0-7.fc20 works

Comment 6 Fedora Update System 2014-03-26 09:05:51 UTC
open-vm-tools-9.4.0-7.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/open-vm-tools-9.4.0-7.fc19

Comment 7 Fedora Update System 2014-03-26 09:06:31 UTC
open-vm-tools-9.4.0-7.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/open-vm-tools-9.4.0-7.el6

Comment 8 Fedora Update System 2014-03-26 17:39:11 UTC
Package open-vm-tools-9.4.0-7.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing open-vm-tools-9.4.0-7.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2014-0967/open-vm-tools-9.4.0-7.el6
then log in and leave karma (feedback).

Comment 9 Sitsofe Wheeler 2014-03-26 22:43:53 UTC
There's no dependency on which with open-vm-tools-9.4.0-7.fc20 so suspend breaks...

Comment 10 Ravindra Kumar 2014-03-26 22:52:45 UTC
Sigh.. not sure how I missed it. I will fix it. Thanks for reporting.

Comment 11 Fedora Update System 2014-03-26 23:40:44 UTC
open-vm-tools-9.4.0-8.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/open-vm-tools-9.4.0-8.fc20

Comment 12 Sitsofe Wheeler 2014-03-27 13:21:00 UTC
Doing
yum install http://kojipkgs.fedoraproject.org//packages/open-vm-tools/9.4.0/8.fc20/x86_64/open-vm-tools-9.4.0-8.fc20.x86_64.rpm
pulls down the missing dependencies (including which) and suspend now works. Resolved?

Comment 13 Ravindra Kumar 2014-03-27 17:22:40 UTC
(In reply to Sitsofe Wheeler from comment #12)
> Doing
> yum install
> http://kojipkgs.fedoraproject.org//packages/open-vm-tools/9.4.0/8.fc20/
> x86_64/open-vm-tools-9.4.0-8.fc20.x86_64.rpm
> pulls down the missing dependencies (including which) and suspend now works.
> Resolved?

I would think so. My understanding is Bodhi will resolve the bug automatically once update gets +3 karma.

Comment 14 Ravindra Kumar 2014-03-27 17:23:44 UTC
Thanks for testing this Sitsofe!

Comment 15 Ravindra Kumar 2014-04-03 01:24:17 UTC
Sitsofe, could you please provide +1 karma to the package as you have tested it?

Comment 16 Sitsofe Wheeler 2014-04-03 15:30:13 UTC
I thought I had on 2014-04-03 - I'm the first Anonymous Tester on https://admin.fedoraproject.org/updates/open-vm-tools-9.4.0-8.fc20 . Perhaps because I don't have a Fedora login it doesn't count?

Comment 17 Richard W.M. Jones 2014-04-03 15:36:03 UTC
The rules are complex -- not even I'm fully aware of them --
and they could include that anonymous votes don't count.

Anyhow the good news is that after ~ 7 days in testing, the
update will get automatically pushed to stable (provided it
doesn't attract any negative votes), so all you have to do
is wait.

Comment 18 Richard W.M. Jones 2014-04-03 15:37:30 UTC
Actually it may not happen automatically.  However Ravindra
should get an email about it with a link that will allow him
to push the update to stable.

Comment 19 Ravindra Kumar 2014-04-03 20:05:19 UTC
Thanks Sitsofe. I saw one vote and I was guessing it to be from you. I tried to vote with my testing but that also does not count. Like Richard suggested, I will wait and push it to stable when I get a notification from Bodhi.

Thanks for testing!

Comment 20 Fedora Update System 2014-04-11 20:48:37 UTC
open-vm-tools-9.4.0-8.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2014-04-15 15:26:45 UTC
open-vm-tools-9.4.0-8.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2014-04-15 15:43:57 UTC
open-vm-tools-9.4.0-8.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.