Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1045852 - system-config-printer network problem
Summary: system-config-printer network problem
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 20
Hardware: i686
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-22 14:59 UTC by Jxanti.jx
Modified: 2014-01-10 15:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-10 13:58:19 UTC
Type: ---


Attachments (Terms of Use)
Screenshots (156.70 KB, image/png)
2013-12-22 15:03 UTC, Jxanti.jx
no flags Details
tar.gz of screenshots (339.27 KB, application/gzip)
2013-12-22 15:08 UTC, Jxanti.jx
no flags Details
Screendumps (551.40 KB, application/gzip)
2014-01-02 21:57 UTC, Jxanti.jx
no flags Details
Requested information (104.69 KB, application/x-gzip)
2014-01-03 16:39 UTC, Jxanti.jx
no flags Details
UBUNTU screenshots of printerinstall (570.05 KB, application/gzip)
2014-01-08 14:58 UTC, Jxanti.jx
no flags Details
New printer install of today (295.84 KB, application/gzip)
2014-01-09 19:26 UTC, Jxanti.jx
no flags Details

Description Jxanti.jx 2013-12-22 14:59:49 UTC
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0
Build Identifier: 

I use a hp deskjet 3520 e-all-in-one printer via my home network.
From F20 Mate I use system-config-printer to install. It has to search the printer and I get what you see in printer1.png. the URI 
hp:/net/Deskjet_3520_series?zc=HP28924A5F69DB Using hplip-gui for remote control of the printer I get printer2.png. hplip-gui does not see the printer.
Than I have to change the URI manually in 
hp:/net/Deskjet_3520_series?ip=192.168.1.6 (this is possible because I know the ip of the printer.) see printshot printer3.png, printer4.png and printer5.png
Question: is it possible that system-config-printer automatically finds the ip address?

Reproducible: Always

Steps to Reproduce:
1.Install F20 Mate
2.Install the HP Deskjet 3520 network printer with system-config-printer
3.Use of hplip-gui for the remote control is possible after adapting the URI of the printer
Actual Results:  
I explained allready in the details above.


I added the screenshots

Comment 1 Jxanti.jx 2013-12-22 15:03:11 UTC
Created attachment 840359 [details]
Screenshots

Comment 2 Jxanti.jx 2013-12-22 15:08:34 UTC
Created attachment 840360 [details]
tar.gz of screenshots

Comment 3 Tim Waugh 2014-01-02 15:41:26 UTC
This seems like a problem with HPLIP.

What does 'hp-probe -b net' say?

Comment 4 Jxanti.jx 2014-01-02 21:55:34 UTC
(In reply to Tim Waugh from comment #3)
> This seems like a problem with HPLIP.
> 
> What does 'hp-probe -b net' say?

Thanks for your reaction.(happy new year)

To answer your question I did a new install of F20Mate
I installed HPLIP because I missed that in former setup of the printer.
During activation of config-system-printer the system proposed to adapt the firewall. I accepted that. Than I did a restart of the printer.
After searching for the network printer it found the ip address (added after
hp:/net/Deskjet_3520_series?zc=HP28924A5F69DB (192.168.1.6)
See my attached screendumps:(in Screendumps.tar.gz)
1: But as you can see at the URI their is no ip URI but an zc=..uri
I tried to make a testpage but that is not possible
2: As you asked I did a hp-probe -b net.
Probably a firewall problem?
I enclose the screendumps about the firewall dumps 3,4,5 and 6

I know if I change the URI manually to hp:/net/Deskjet_3520_series?ip=192.168.1.6
The printer works

To get some more understanding: what does the zc URI mean.
And to conclude as I often said the deb distros mostly find the ip automatically

Regards Thies;]

Comment 5 Jxanti.jx 2014-01-02 21:57:51 UTC
Created attachment 844749 [details]
Screendumps

See screendumps for Tim Waugh

Comment 6 Tim Waugh 2014-01-03 09:29:03 UTC
Instead of the IP address, the Zeroconf name (i.e. mdns) ought to be sufficient. 

What does "hp-makeuri -c 192.168.1.6" say?

Comment 7 Jxanti.jx 2014-01-03 16:38:13 UTC
(In reply to Tim Waugh from comment #6)
> Instead of the IP address, the Zeroconf name (i.e. mdns) ought to be
> sufficient. 
> 
> What does "hp-makeuri -c 192.168.1.6" say?

I reinstalled the printer and accepted again with root pwd the changes of the firewall.

See  screendumps 1,2 and 3.
3 answers your question: 
[xantippe@localhost ~]$ hp-makeuri -c 192.168.1.6
hp:/net/Deskjet_3520_series?ip=192.168.1.6
[xantippe@localhost ~]$

Comment 8 Jxanti.jx 2014-01-03 16:39:17 UTC
Created attachment 845017 [details]
Requested information

Comment 9 Tim Waugh 2014-01-06 15:39:15 UTC
I'm trying to understand how you start off with the URI hp:/net/Deskjet_3520_series?zc=HP28924A5F69DB.

What exactly are you doing when you "search for the network printer" -- are you clicking on "Find Network Printer" and entering the IP address in the box and clicking Find, or something else?

Comment 10 Jxanti.jx 2014-01-06 20:32:52 UTC
(In reply to Tim Waugh from comment #9)
> I'm trying to understand how you start off with the URI
> hp:/net/Deskjet_3520_series?zc=HP28924A5F69DB.
> 
> What exactly are you doing when you "search for the network printer" -- are
> you clicking on "Find Network Printer" and entering the IP address in the
> box and clicking Find, or something else?

What I do is this: I click on "Find Network Printer" (after I restart my printer to make sure the system can find something) Then the system warned me the changes in the firewall and I accepted that as root. Then I got the URI as you stated above. Because it is not possible to make a testpage and hplip-gui does not see the printer I changed the URI with the ip address see my first screendumps. 

The change of the URI has been done in system-config-printer after clicking on the printer icon.

I can do a new installation of the printer if you like do have more details.

All the screendumps I sent follow my installation work.

Comment 11 Jxanti.jx 2014-01-08 14:55:43 UTC
(In reply to Jxanti.jx from comment #10)
> (In reply to Tim Waugh from comment #9)
> > I'm trying to understand how you start off with the URI
> > hp:/net/Deskjet_3520_series?zc=HP28924A5F69DB.
> > 
> > What exactly are you doing when you "search for the network printer" -- are
> > you clicking on "Find Network Printer" and entering the IP address in the
> > box and clicking Find, or something else?
> 
> What I do is this: I click on "Find Network Printer" (after I restart my
> printer to make sure the system can find something) Then the system warned
> me the changes in the firewall and I accepted that as root. Then I got the
> URI as you stated above. Because it is not possible to make a testpage and
> hplip-gui does not see the printer I changed the URI with the ip address see
> my first screendumps. 
> 
> The change of the URI has been done in system-config-printer after clicking
> on the printer icon.
> 
> I can do a new installation of the printer if you like do have more details.
> 
> All the screendumps I sent follow my installation work.

I include information about the way I do it under UBUNTU(13.10), see the attached screenshots. No questions about the firewall.
I did not enter the ip address of my printer it has been found automatically, with the right URI.

Comment 12 Jxanti.jx 2014-01-08 14:58:35 UTC
Created attachment 847186 [details]
UBUNTU screenshots of printerinstall

Screenshots of printer installing under UBUNTU

Comment 13 Tim Waugh 2014-01-09 13:34:02 UTC
What do you type into the "Host:" box before clicking "Find"?

Comment 14 Jxanti.jx 2014-01-09 14:19:22 UTC
(In reply to Tim Waugh from comment #13)
> What do you type into the "Host:" box before clicking "Find"?

I do not type anything in the "Host:" box I just click "Find"

Comment 15 Tim Waugh 2014-01-09 16:44:28 UTC
Does that entry still appear if you don't click Find at all?  I'm not convinced clicking Find for an empty hostname will find anything.

Comment 16 Jxanti.jx 2014-01-09 19:24:55 UTC
Before I choose Find I see only the URI box.
I enclose again some screenshots(see "New printer install 09012014.tar.gz").
Firstly a scan of the printerstatusreport that gives also the HOSTNAME HP5F69DB
Screenshot1 After clicking on Find I got the HOST box and I put in the above mentioned HOSTNAME
Screenshot2 After clicking on Find(Host) I got the message No printer was found at that address.
Screenshot3 and 4  After entering the right ip address A Jetdirect(192.168.1.6) has been found.
(before I started this new printer installation I installed HPLIP + HPLIP-GUI)
See screenshot 4.
Screenshot5 gives what I see when clicking on the printer icon. The right URI with the ip address.

=====

To have a double check I did a new printer install and than I got, see screenshot "Newinstall.png", before I click on "find network printer" automatically my printer "HP Deskjet 3520"

=====

For me it looks like a DNS problem??

Comment 17 Jxanti.jx 2014-01-09 19:26:39 UTC
Created attachment 847785 [details]
New printer install of today

New printer install perhaps answering your question.

Comment 18 Tim Waugh 2014-01-10 13:58:19 UTC
So, that shows me how you ended up with the device URI containing the IP address (ip=).

But in the first comment you said you have a device URI discovered that contained the Zeroconf hostname (zc=).

I think the printer is advertising its Zeroconf hostname on its web page, so trying to "Find" that name causes HPLIP to return a URI bound to that name.

Everything seems to be working correctly, except that sometimes Zeroconf is working for you and sometimes it isn't.

The fact that the printer is not discovered without you needing to click "Find" suggests to me that your firewall rules are too strict, or perhaps the printer's implementation of Zeroconf is buggy (the fact that it has changed its Zeroconf hostname suggests that).

I don't think there is a Fedora bug here.

Comment 19 Jxanti.jx 2014-01-10 15:30:38 UTC
(In reply to Tim Waugh from comment #18)
> So, that shows me how you ended up with the device URI containing the IP
> address (ip=).
> 
> But in the first comment you said you have a device URI discovered that
> contained the Zeroconf hostname (zc=).
> 
> I think the printer is advertising its Zeroconf hostname on its web page, so
> trying to "Find" that name causes HPLIP to return a URI bound to that name.
> 
> Everything seems to be working correctly, except that sometimes Zeroconf is
> working for you and sometimes it isn't.
> 
> The fact that the printer is not discovered without you needing to click
> "Find" suggests to me that your firewall rules are too strict, or perhaps
> the printer's implementation of Zeroconf is buggy (the fact that it has
> changed its Zeroconf hostname suggests that).
> 
> I don't think there is a Fedora bug here.

I still do not understand why the .deb distros do not give this problem.
If you think it is in a buggy zeroconf working here, that should also be a problem for other distros.

Do you know a difference in those systems compaired with the Fedora system?

The only thing I can think of is the low signal of my internet wifi modem. But also that gives no problem for other distros.

Can you advice me where to get more help (in this field) to compare the differences between lets say Fedora and Ubuntu?


Note You need to log in before you can comment on or make changes to this bug.