Bug 1045866 - [abrt] dnf-0.3.11-3.git7bdc9e1.fc19: base.py:379:read_all_repos:OSError: [Errno 2] No such file or directory: '///etc/yum.repos.d/mariadb-testday.repo'
Summary: [abrt] dnf-0.3.11-3.git7bdc9e1.fc19: base.py:379:read_all_repos:OSError: [Err...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:04653dc534a35457c8a956e90b5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-22 16:35 UTC by Honza Horak
Modified: 2014-09-30 23:41 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-02 13:50:12 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.20 KB, text/plain)
2013-12-22 16:35 UTC, Honza Horak
no flags Details
File: environ (115 bytes, text/plain)
2013-12-22 16:35 UTC, Honza Horak
no flags Details

Description Honza Horak 2013-12-22 16:35:12 UTC
Description of problem:
Nothing, some daemon on background failed.
File /etc/yum.repos.d/mariadb-testday.repo is empty, which can be important.

Version-Release number of selected component:
dnf-0.3.11-3.git7bdc9e1.fc19

Additional info:
reporter:       libreport-2.1.9
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.11.10-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
base.py:379:read_all_repos:OSError: [Errno 2] No such file or directory: '///etc/yum.repos.d/mariadb-testday.repo'

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 292, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 112, in _main
    cli.configure(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1242, in configure
    self._configure_repos(opts)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 987, in _configure_repos
    self.base.read_all_repos()
  File "/usr/lib/python2.7/site-packages/dnf/yum/base.py", line 379, in read_all_repos
    thisrepo_age = os.stat(repofn)[8]
OSError: [Errno 2] No such file or directory: '///etc/yum.repos.d/mariadb-testday.repo'

Local variables in innermost frame:
thisrepo_age: 1378726624
repo_config_age: 1378726624
reposdir: '///etc/yum.repos.d'
self: <dnf.cli.cli.YumBaseCli object at 0x7fbbbc73c290>
repofn: '///etc/yum.repos.d/mariadb-testday.repo'

Comment 1 Honza Horak 2013-12-22 16:35:17 UTC
Created attachment 840374 [details]
File: backtrace

Comment 2 Honza Horak 2013-12-22 16:35:22 UTC
Created attachment 840375 [details]
File: environ

Comment 3 Honza Horak 2013-12-22 16:38:48 UTC
(In reply to Honza Horak from comment #0)
> File /etc/yum.repos.d/mariadb-testday.repo is empty, which can be important.

Actually the file was a dangling symlink, so not empty, but non-existing effectively.

Comment 4 Ales Kozumplik 2014-01-02 06:57:36 UTC
Hi Honza, thanks for the report we'll take a look. Do you accidentaly have the opportunity to test if this is still an issue in F20 (i.e. with dnf-0.4.x version)?

Comment 5 Ales Kozumplik 2014-01-02 13:50:12 UTC
Tested with F20's dnf-0.4.10, I am unable to reproduce. We've also dropped the old age checking mechanism (03cabe2c60fde7e2bed5fda593da4cb67e586c50) so this shouldn't be an issue any more. Closing for now, if you manage to reproduce with a fairly new DNF please reopen.


Note You need to log in before you can comment on or make changes to this bug.