Bug 1045977 - win7sp1-32 82599EB pf driver can not work
Summary: win7sp1-32 82599EB pf driver can not work
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm
Version: 7.0
Hardware: i386
OS: Windows
medium
medium
Target Milestone: rc
: ---
Assignee: Alex Williamson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-23 05:21 UTC by Jun Li
Modified: 2014-03-18 21:10 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-18 21:10:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
82599EB PF driver issue screen shot (260.42 KB, image/png)
2014-02-17 04:42 UTC, Jun Li
no flags Details
devmgmt.msc-see.png (64.72 KB, image/png)
2014-02-17 04:43 UTC, Jun Li
no flags Details

Description Jun Li 2013-12-23 05:21:36 UTC
Description of problem:
82599EB pf driver inside win7sp1-32 guest can install as normal but not work.
Download this driver from:
https://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&changeLang=true&DwnldId=18713

Version-Release number of selected component (if applicable):
qemu-kvm-rhev-1.5.3-21.el7.x86_64
3.10.0-61.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1.Boot win7sp1-32 guest with 82599EB pf.
# /usr/libexec/qemu-kvm -S -M pc-i440fx-rhel7.0.0 -cpu SandyBridge -enable-kvm -m 2G -smp 2,sockets=2,cores=1,threads=1 -name juli -uuid 355a2475-4e03-4cdd-bf7b-5d6a59edaa68 -rtc base=localtime,clock=host,driftfix=slew -device virtio-scsi-pci,bus=pci.0,addr=0x5,id=scsi0 -drive file=/home/juli/win7sp1-32.qcow2_v3,if=none,id=drive-scsi0-0-0,media=disk,cache=none,format=qcow2,werror=stop,rerror=stop,aio=native -device scsi-hd,drive=drive-scsi0-0-0,bus=scsi0.0,scsi-id=0,lun=0,id=juli,bootindex=0 -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -k en-us -boot menu=on,reboot-timeout=-1,strict=on -qmp tcp:0:4488,server,nowait -spice port=5969,disable-ticketing -vga qxl -global qxl-vga.revision=3 -monitor stdio -monitor unix:/tmp/monitor1,server,nowait \
-device vfio-pci,host=05:00.0,id=hostnet_PF
2.Download pf driver and install it inside guest.


Actual results:
this pf driver can not works as well.
The driver give the following info:
This device cannot start. (Code 10)

Expected results:
win7sp1-32 pf driver can works well.

Additional info:

Comment 6 Alex Williamson 2014-01-23 04:31:59 UTC
Was the win7sp1-32bit guest fully updated?  I don't have an 82599EB, but I was able to assign an X540-AT2 PF to a win7sp1 guest.  The driver initially would not install saying it didn't detect and Intel adapter.  After ~400MB of Windows Update, it installs and works as expected.

Comment 7 Jun Li 2014-01-23 09:08:03 UTC
(In reply to Alex Williamson from comment #6)
> Was the win7sp1-32bit guest fully updated?  I don't have an 82599EB, but I
> was able to assign an X540-AT2 PF to a win7sp1 guest.  The driver initially
> would not install saying it didn't detect and Intel adapter.  After ~400MB
> of Windows Update, it installs and works as expected.

Hi Alex,
   I am waiting for reserving this machine. somebody is using this machine.

Best Regards,

Jun Li

Comment 9 Jun Li 2014-02-17 04:40:20 UTC
(In reply to Alex Williamson from comment #6)
> Was the win7sp1-32bit guest fully updated?  I don't have an 82599EB, but I
> was able to assign an X540-AT2 PF to a win7sp1 guest.  The driver initially
> would not install saying it didn't detect and Intel adapter.  After ~400MB
> of Windows Update, it installs and works as expected.

After win7sp1-32 guest update, can not install 82599 pf driver still. It will give warning: "Can not install drivers. No Intel(R) Adapters are present in this computer.". The screen shot is as the attachment.
---------
(qemu)info qtree
...
  Bus  0, device   3, function 0:
    Ethernet controller: PCI device 8086:10fb
      IRQ 11.
      BAR0: 64 bit memory at 0xfc000000 [0xfc07ffff].
      BAR2: I/O at 0xc060 [0xc07f].
      BAR4: 64 bit memory at 0xfc150000 [0xfc153fff].
      BAR6: 32 bit memory at 0xffffffffffffffff [0x0007fffe].
      id "hostnet_PF"
  Bus  0, device   4, function 0:
    Ethernet controller: PCI device 1af4:1000
      IRQ 0.
      BAR0: I/O at 0xc080 [0xc09f].
      BAR1: 32 bit memory at 0xfc156000 [0xfc156fff].
      BAR6: 32 bit memory at 0xffffffffffffffff [0x0003fffe].
      id "net1"
...

Comment 10 Jun Li 2014-02-17 04:42:56 UTC
Created attachment 863943 [details]
82599EB PF driver issue screen shot

Comment 11 Jun Li 2014-02-17 04:43:48 UTC
Created attachment 863945 [details]
devmgmt.msc-see.png

Comment 12 Alex Williamson 2014-02-28 18:30:27 UTC
Can a system with this configuration be made available for debug?  We have no systems with 82599EB in the development lab and X540 has not reproduced the issue.

Comment 22 Alex Williamson 2014-03-18 21:10:51 UTC
Reproduced.  Testing various versions of the Intel driver I find:

18.4: Works
18.5: Works
18.6: Works
18.7: Works
18.8.1: Fail
19.0: Fail

In all working cases the device is found and listed in device manager as an X520 and the Intel driver utilities available through device manager appear to work.  I can't do any network testing since the provided test system does not have link.

And the smoking gun, from the 18.8.1 release notes (http://downloadmirror.intel.com/23684/eng/readme.txt):

Intel 10GbE Network Adapter Notes
=================================

Release 18.7 is the last release in which Intel 10GbE Network adapters support
32-bit Microsoft Windows. Starting with Release 18.8, Intel 10GbE Network adapters do not support the following operating systems:
 * Microsoft Windows 7 (32-bit)
 * Microsoft Windows 8 (32-bit)
 * Microsoft Windows 8.1 (32-bit)

QED


Note You need to log in before you can comment on or make changes to this bug.