Bug 104600 - Kernel panic: kmem_cache_reap [kernel] 0x375 with swapping off
Kernel panic: kmem_cache_reap [kernel] 0x375 with swapping off
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Larry Woodman
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-17 14:33 EDT by Suhua Ding
Modified: 2007-11-30 17:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 19:45:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Suhua Ding 2003-09-17 14:33:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
This happened on kernel .435 during a tpc-c run with swapping turned off.  It
probably wasn't good practice to do this, but here is the info:

invalid operand: 0000
oprofile lp parport ide-cd cdrom autofs tg3 floppy microcode keybdev
mousedev hid input usb-ohci usbcore ext3 jbd megaraid2 aic7xxx sd_mod
scsi_mod 
CPU:    4
EIP:    0060:[<0214fe75>]    Not tainted
EFLAGS: 00010097

EIP is at kmem_cache_reap [kernel] 0x375 (2.4.21-b1.435.entcustom)
eax: 0239eaf8  ebx: 00000023  ecx: 00000000  edx: ef42a000
esi: 2774035c  edi: 000dc9ab  ebp: 000064d9  esp: 29b31f10
ds: 0068  es: 0068  ss: 0068
Process cat (pid: 6779, stackpage=29b31000)
Stack: 9cb03c80 022b6141 000003c0 000000f0 0000002b 00001000 0000002b
0000002b
      00000001 ff000000 00001000 00000202 00000000 0000002b 0000016e
00000000
      9cb03c80 2774035c 000009ea 02181a23 9cb03c80 2774035c 29b31f74
9cb03c98
Call Trace:  [<02181a23>] seq_read [kernel] 0x173 (0x29b31f5c)
[<02161153>] sys_read [kernel] 0xa3 (0x29b31f94)
[<0216b629>] sys_fstat64 [kernel] 0x49 (0x29b31fa8)

Code: Bad EIP value.

Kernel panic: Fatal exception

----
The kernel was rebuild to include the megaraid2 driver patch to get rid of scsi
errors (driver and firmware going out of sync). 

Version-Release number of selected component (if applicable):
kernel .435

How reproducible:
Didn't try

Steps to Reproduce:
1. tpc-c run with swapping turned off
2.
3.
    

Additional info:
Comment 2 Larry Woodman 2003-09-18 11:31:58 EDT
Please reproduce this bug with the release candidate kernel that is not custom
built.

http://people.redhat.com/~lwoodman/.for_oracle/kernel-hugemem-2.4.21-2.EL.i686.rpm

Thanks, Larry Woodman


Comment 3 Suhua Ding 2003-09-18 15:41:28 EDT
There is a megaraid2 patch in bugzilla 102333.  We 
want to try the kernel on the Dell system and need
this patch.  Either a custom build kernel with this 
driver patch, or an updated driver with this patch
that will work with this release candidate.

Van
Comment 4 Dave Anderson 2003-09-25 10:10:40 EDT
Because the backtrace is seemingly nonsensical, i.e., no linkage
to kmem_cache_reap(), there's nothing to work with.  Please try
the following debug kernel, which has the megaraid2 patch from 
BZ #102333 applied:

http://people.redhat.com/~anderson/.for_oracle/kernel-hugemem-2.4.21-3.EL.md2.i686.rpm
Comment 5 Larry Woodman 2004-04-21 10:56:51 EDT
Suhua, is this still a problem with the latest RHEL3 kernel or can we
close the bug now?

Larry
Comment 6 Larry Woodman 2004-11-29 15:38:02 EST
Suhua, we need to close this bug if it is no longer a problem.  Can
you verify that it is fixed in RHEL3-U4/

Larry Woodman
Comment 7 Ernie Petrides 2005-10-05 19:45:43 EDT
Closing due to lack of response.

Note You need to log in before you can comment on or make changes to this bug.