Bug 1046059 - Web console says -1 is an "Invalid numeric value" while setting reconnect attempts on connection factory
Summary: Web console says -1 is an "Invalid numeric value" while setting reconnect att...
Keywords:
Status: CLOSED DUPLICATE of bug 1018800
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Console
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Harald Pehl
QA Contact: Jakub Cechacek
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-23 12:23 UTC by varsha
Modified: 2015-02-01 23:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-09 12:38:44 UTC
Type: Bug


Attachments (Terms of Use)
"Invalid numeric value" message shown in web console while setting reconnect-attempts = -1 (98.67 KB, image/png)
2013-12-23 12:23 UTC, varsha
no flags Details

Description varsha 2013-12-23 12:23:46 UTC
Created attachment 840791 [details]
"Invalid numeric value" message shown in web console while setting reconnect-attempts = -1

Description of problem:
Web console says -1 is an "Invalid numeric value" while setting ReconnectAttempts on connection factory. Also it shows ReconnectAttempts value 0 if it is set to -1 in configuration file.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Set reconnect-attempts value through CLI as below :

[standalone@localhost:9999 /] /subsystem=messaging/hornetq-server=default/connection-factory=RemoteConnectionFactory/:write-attribute(name=reconnect-attempts,value=-1)
{"outcome" => "success"}
[standalone@localhost:9999 /]

2. check it through Web console, it shows value set to 0.

3. Try to edit value to -1, it gives message as "Invalid numeric value".


Actual results:


Expected results:


Additional info:

Comment 1 Heiko Braun 2014-07-09 12:38:44 UTC

*** This bug has been marked as a duplicate of bug 1018800 ***


Note You need to log in before you can comment on or make changes to this bug.