Bug 1046153 - No sound - Fresh Fedora 20 install - (Now works for me after kernel 3.12.7-300.fc20.x86_64 update)
Summary: No sound - Fresh Fedora 20 install - (Now works for me after kernel 3.12.7-30...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-23 21:02 UTC by Bugreporta
Modified: 2014-11-22 16:06 UTC (History)
24 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-27 12:15:13 UTC


Attachments (Terms of Use)
'alsa-info.sh --no-upload' output (pre kernel update) (38.49 KB, text/plain)
2013-12-23 21:02 UTC, Bugreporta
no flags Details
'alsa-info.sh --no-upload' post kernel update (38.83 KB, text/plain)
2013-12-23 21:06 UTC, Bugreporta
no flags Details
Fedora 19 sound settings (For comparison) (105.17 KB, image/png)
2013-12-23 21:11 UTC, Bugreporta
no flags Details
Fedora 20 sound settings post kernel update (60.81 KB, image/png)
2013-12-23 21:20 UTC, Bugreporta
no flags Details
alsa-info.sh --no-upload (43.55 KB, text/plain)
2013-12-28 22:01 UTC, Slobodan Tomic
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1048472 None None None Never

Internal Links: 1048472

Description Bugreporta 2013-12-23 21:02:31 UTC
Created attachment 840944 [details]
'alsa-info.sh --no-upload' output (pre kernel update)

I replaced my Fedora 19 install with a Fedora 20 install (not update). 

The install was successful but I had no sound. I tried both DVD install and network install but it made no difference. I tried a Fedora 19 LiveCD to ensure my hardware was OK and sound worked fine.

The only option available in F20 was - 'Digital Output (S/PDIF) - Built-in Audio'. The options in F19 also included 'Analog Output - Built-in Audio'. See attached screenshots

I followed the steps in https://fedoraproject.org/wiki/How_to_debug_sound_problems up to (but not including) Mixer Settings but it made no difference.

See attachment for alsa-info.sh --no-upload output (pre kernel upgrade)

After a kernel update (from 3.11.10-301.fc20.x86_64 to 3.12.5-302.fc20.x86_64)  I followed the steps again. This time removing pulseaudio made a difference. I got some sound and was able to ajust it using alsamixer. However the Sound options still didn't recognise my 5.1 surround sound (though the speakers worked I wasn't able to use the speaker sound test facility).

See attachment for alsa-info.sh --no-upload output (post kernel upgrade)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install Fedora 20
2.
3.

Actual results:



Expected results:

Sound from speakers.

Additional info:

Comment 1 Bugreporta 2013-12-23 21:06:55 UTC
Created attachment 840945 [details]
'alsa-info.sh --no-upload' post kernel update

Comment 2 Bugreporta 2013-12-23 21:11:16 UTC
Created attachment 840946 [details]
Fedora 19 sound settings (For comparison)

Comment 3 Bugreporta 2013-12-23 21:20:50 UTC
Created attachment 840958 [details]
Fedora 20 sound settings post kernel update

Fedora 20 sound settings post kernel update. prior to update to 3.12 the HDMI option wasn't present

Comment 4 Sybren 2013-12-27 07:34:24 UTC
Same problem (sound with (F18 and) F19, no sound after fresh install of F20.
But even after update to kernel 3.12.5 not any sound, even after removing and installing pulseaudio.
The subsystem-numbers in "my" alsa-info-file are different.
I too see HDMI-items which are not useful as a speakerless screen is attached to my desktop.
I don't have a separate soundcard, sound is produced by the motherboard (Asus F1A75-V EVO FM1 A75 4xDDR3 ATX).

Comment 5 Sybren 2013-12-27 20:20:34 UTC
Sound is working with Live-edition of OpenMandriva2013.0

One difference between OpenMandriva2013 en Fedora 20 is in output of 'pactl stat':
OpenMandriva2013:
  Default Sink: alsa_output.pci-0000_00_14.2.analog-stereo
Fedora 20:
  Default Sink: alsa_output.pci-0000_00_14.2.iec958-stereo

Fedora 20 shows no "analog-stereo"-sink on my computer. Output of 'pactl list short sinks':
0	alsa_output.pci-0000_00_01.1.hdmi-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED
1	alsa_output.pci-0000_00_14.2.iec958-stereo	module-alsa-card.c	s16le 2ch 44100Hz	SUSPENDED

Comment 6 Slobodan Tomic 2013-12-28 21:59:54 UTC
I can confirm identical problem here (upgraded FC19 to FC20).

Comment 7 Slobodan Tomic 2013-12-28 22:01:20 UTC
Created attachment 842793 [details]
alsa-info.sh --no-upload

Comment 8 Mihkel Vain 2013-12-29 22:47:39 UTC
Same problem here... no analogue output after FC19 to FC20 upgrade.

Comment 9 Karl Latiss 2013-12-30 00:51:16 UTC
I had the same problem and found that my (stereo) speakers were plugged in to the black connector (Rear surround left/right channel audio out). This configuration had worked for a number of Fedora releases but stopped working with FC20.

Moving the speakers to the green connector (Line Out) fixed this for me.

Comment 10 Slobodan Tomic 2013-12-30 18:17:42 UTC
No, tried out connectors but that didn't help. Problem is that digial output is default/only recognized. Fixed problem by adding following u /etc/pulse/default.pa

load-module module-alsa-sink device=hw:0,0
set-default-sink 0

Details described here: https://wiki.archlinux.org/index.php/PulseAudio/Examples#Defaulting_an_Analog_Output_Source

Comment 11 Tore H. Larsen 2013-12-31 07:25:04 UTC
Same here.

Comment 12 Greg McGary 2014-01-03 05:19:08 UTC
(In reply to Slobodan Tomic from comment #10)
> No, tried out connectors but that didn't help. Problem is that digial output
> is default/only recognized. Fixed problem by adding following u
> /etc/pulse/default.pa
> 
> load-module module-alsa-sink device=hw:0,0
> set-default-sink 0
> 
> Details described here:
> https://wiki.archlinux.org/index.php/PulseAudio/
> Examples#Defaulting_an_Analog_Output_Source

I had working sound from F19 using the black connector.

With F20, sound no longer worked, and the analog output was absent from [Sound / Output] settings.

When I moved the speaker connection to the green socket, analog output returned as an option in [Sound / Output] settings, but still no sound.

I followed the procedure in https://wiki.archlinux.org/index.php/PulseAudio/Examples#Defaulting_an_Analog_Output_Source without success.

Comment 13 Lukas Zapletal 2014-01-04 13:18:06 UTC
I am experiencing issues on my laptop (T430s), when I connect/unconnect audiojack or dock/undock, pulseaudio does not switch output correctly. This is obviously not a kernel problem.

Any workaround for this?

Comment 14 thcourbon 2014-01-04 23:13:39 UTC
I'm experiencing the same issue as previous poster, upon changing the speaker connexion around I can get an line out analog ouput to be displayed in the Gnome sound control panel, but with no sound.

Following the archlinux wiki make an "internal audio" to show up in the control panel but without any profil I can select. And still no sound.

I don't believe this is related to the issues experienced by Lukas Zapletal since to trigger it you don't have to dock/undock or plug anything.

I fail to see why it would __obviously__ not be a kernel issue, but I'm open to suggestion...

Comment 15 Peter Lawler 2014-01-05 02:24:42 UTC
Experienced very similar to OP this on my desktop machine. What particularly was driving my frustration was that I was analog getting sound at the default login screen (by manipulating the volume slider, sound events for VolUp and VolDown were being triggered and I could hear them)
However, after logging in to Gnome 3, the only audio device 'visible' in sound preferences was the S/PDIF connector. On looking at pavucontrol, all analog outputs were set as 'unplugged'.
After doing what is suggested in #comment10, I've got analog sound back.
I'm wondering if those who have reported they are experiencing the original problem whether they have sound at the login screen but not after logging in, or no sound on the login screen.

Comment 16 chris 2014-01-05 03:17:08 UTC
Same here. 
I have sound at the login screen, but after login I can only choose between hdmi and digital output.

Comment 17 Tim Chappell 2014-01-05 04:27:56 UTC
I just installed FC 20 and have no HDMI or alsa pulsaudio output.  The devices showed as not connected. I then unplugged the cable from the back of the pc and now the pavucontrol gui only shows a "Dummy Output" virtual output device and not actual hardware.

Comment 18 Peter Lawler 2014-01-05 19:47:34 UTC
Before using the workaround in #comment10, I tried re-plugging my analog outs to get the thing to recognise them, but with no success. I don't know whether we're looking at one or two bugs here, but I'm not entirely convinced this is a kernel issue due to the sound working on the login screen for at least two people.
I'll try and get my asound debug foo uploaded later today.

Comment 19 Tim Chappell 2014-01-06 06:03:43 UTC
(In reply to Tim Chappell from comment #17)
> I just installed FC 20 and have no HDMI or alsa pulsaudio output.  The
> devices showed as not connected. I then unplugged the cable from the back of
> the pc and now the pavucontrol gui only shows a "Dummy Output" virtual
> output device and not actual hardware.

I did get the alsa audio out to work. After rebooting (cold boot), I re-plugged the speaker cable into the green plug like Karl Latiss above suggested.

Comment 20 Sybren 2014-01-08 18:59:42 UTC
The advice given in Comment 10 did help me to get sound back.
In default.pa I also commented out some lines. All original lines between
"load-module module-switch-on-port-available"
and
".ifexists module-bluetooth-policy.so"
do have one or more # at the start, although the suggested lines from Comment 10 have been inserted here.
After the out-commenting the HDMI and SPDIF have disappeared.
I used alsamixer to get volume of sound at a better level.
The black-green-trick as described in earlier comments did not work for me.

Comment 21 Martin Sourada 2014-01-10 23:29:51 UTC
Not sure if it's the same bug -- but also no sound (both internal repros with headphones unplugged and headphones plugged in) on internal intel sound card after upgrade (f19 -> f20). Strangely enough, external USB soundcard worked fine. After some search I noticed Headphones switch (in alsamixer) on the intel sound card was set 0 %, setting it to 100 % resolved the issue for me.

Comment 22 Walo Walthari 2014-01-14 06:21:50 UTC
Thankyou Martin Sourada
After check alsamixer

~]$ alsamixer


 Card: PulseAudio
 Chip: PulseAudio
 View: F3:[Playback] F4: Capture  F5: All
 Item: Master

  00<>00
< Master >

And increase the value, the issue is solved.
Regards

(In reply to Martin Sourada from comment #21)
> Not sure if it's the same bug -- but also no sound (both internal repros
> with headphones unplugged and headphones plugged in) on internal intel sound
> card after upgrade (f19 -> f20). Strangely enough, external USB soundcard
> worked fine. After some search I noticed Headphones switch (in alsamixer) on
> the intel sound card was set 0 %, setting it to 100 % resolved the issue for
> me.

Comment 23 Benjamin Hahne 2014-01-16 10:33:31 UTC
My experience I believe is similar (mirror of initial reporter on Intel hardware):

Fedora 19 -> Fedup -> Fedora 20 = Sound working fine.

Fresh install of F20 = Sound not working, hardware not showing, alsamixer no help, see multiple "Reached target soundcard"s in the systemd startup.

F20 Live CD = Same as fresh install.

F19 Live CD = Sound working fine (was concerned it might have been hardware issue).


Current activities:

Installed F19 on a parallel partition (so I can boot into the failing F20 config if I can be of any value for testing potential fixes).

Fedup'ing this F19 install to F20 (to confirm that did work, I'll roll back to F19 otherwise).


I haven't had to do this kind of thing since F4 -> F5 and F5 -> F6 or playing with the alpha prior to the GNOME 3 release, so I'm a little miffed! ;-)

Comment 24 Bugreporta 2014-01-16 19:29:12 UTC
After updating to latest kernel (3.12.7-300.fc20.x86_64), reinstalling alsa-plugins-pulseaudio, restarting system and updating changing Built-in audio profile in Pavucontrol (configuration tab) to Analog Sound 5.1 Output (unplugged)
audio appears to be working correctly again.

Comment 25 Benjamin Hahne 2014-01-20 13:36:49 UTC
Fedup from F19 -> F20 = working sound.

Still have the "clean" F20 install around if need be.

Comment 26 thcourbon 2014-02-01 16:06:12 UTC
Still no sound here (Fedora 19 -> 20 update). Tried the steps from comment 24 without success...

Comment 27 chris 2014-02-12 12:19:43 UTC
For me the workaround from comment #10 was the solution to have sound after login. So i am not sure if the kernel is to blame for it.

Comment 28 Mike Heller 2014-03-12 20:41:17 UTC
(In reply to Slobodan Tomic from comment #10)
> No, tried out connectors but that didn't help. Problem is that digial output
> is default/only recognized. Fixed problem by adding following u
> /etc/pulse/default.pa
> 
> load-module module-alsa-sink device=hw:0,0
> set-default-sink 0
> 

This solved my sound problem after upgrading from f19 to f20!

Comment 29 Nathan Crubel 2014-03-12 21:27:36 UTC
I tried from comment 10 with no luck.  I was able to switch the plugin between the digital and green colored and would have one speaker with sound.  After reinstalling Fedora 20, sound know works like it did before the upgrade on Fedora 20.

Comment 30 Aleksandar Kostadinov 2014-05-12 15:10:56 UTC
I had luck getting sound to normal by disabling pulse auto spawn in `/etc/pulse/client.conf`. Just FYI for raw ALSA savvy people.

Comment 31 Justin M. Forbes 2014-05-21 19:39:35 UTC
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 20 kernel bugs.

Fedora 20 has now been rebased to 3.14.4-200.fc20.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.

Comment 32 Jeremy Newton 2014-05-22 13:51:49 UTC
(In reply to Aleksandar Kostadinov from comment #30)
> I had luck getting sound to normal by disabling pulse auto spawn in
> `/etc/pulse/client.conf`. Just FYI for raw ALSA savvy people.

Isn't this a bug in pulse audio then, not the kernel?

Comment 33 Bugreporta 2014-05-26 07:26:05 UTC
Reinstalled Fedora yesterday (latest kernel). My issue resolved in curent kernel. Just had to install pavucontrol and select 5.1 analog sound.

Comment 34 Josh Boyer 2014-05-27 12:15:13 UTC
Thanks.


Note You need to log in before you can comment on or make changes to this bug.