Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1046165 - This component has refused to update for at least a year
Summary: This component has refused to update for at least a year
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kde-plasma-nm
Version: 19
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jan Grulich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-23 21:53 UTC by Michael Jordan
Modified: 2013-12-24 15:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-23 23:28:21 UTC
Type: ---


Attachments (Terms of Use)
These same 8 updates have been sitting here for a year. (80.01 KB, application/zip)
2013-12-23 21:57 UTC, Michael Jordan
no flags Details

Description Michael Jordan 2013-12-23 21:53:14 UTC
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0
Build Identifier: 

Updates will not apply to this component

Reproducible: Always

Steps to Reproduce:
No special update required

1. Apply updates to system
2. Updates to this component are not applied
Actual Results:  
This component simply sits in Apper and refuses to update.

Expected Results:  
It should update

I have seen nothing happen since F18

Comment 1 Michael Jordan 2013-12-23 21:57:44 UTC
Created attachment 840962 [details]
These same 8 updates have been sitting here for a year.

Comment 2 Kevin Kofler 2013-12-23 23:28:21 UTC
Because you now have to choose between (the old) kde-plasma-networkmanagement (which is the default in Fedora 19) and (the new) kde-plasma-nm, they use the same internal name now, so you cannot install both anymore. So uninstall one or the other.

When upgrading to Fedora 20 or later, kde-plasma-nm will always replace kde-plasma-networkmanagement.

Comment 3 Michael Jordan 2013-12-24 02:26:45 UTC
I haven't "chosen" between anything. This is the case. At what point were you going to advise the users that they had a choice that they needed to make, and instruct them in how to make it?

i.e., what packages do I need to remove in order to allow these to install?

Comment 4 Michael Jordan 2013-12-24 02:36:06 UTC
I am attempting to remove the "old" packages and I am so far unable to locate the proper sequence to execute this in. Could someone up there point me to some proper documentation on this issue?

Comment 5 Kevin Kofler 2013-12-24 03:08:19 UTC
kde-plasma-nm is not installed by default on Fedora 19, so you must have installed it explicitly.

If you run "yum update" directly, it will tell you what the problem is (that the latest builds of kde-plasma-nm conflict with kde-plasma-networkmanagement, because they are now designed to be a drop-in replacement, which unfortunately means they cannot be installed in parallel anymore). If Apper really doesn't show you any kind of message, that's a limitation of PackageKit/Apper. (It's a well-meaning feature, that it tries to update what it can without the packages that fail to update. If you try running the update again, with only the failing packages left to update, it should be giving you an error about why it's failing to update though. At least it has always done that for me.)

Comment 6 Michael Jordan 2013-12-24 15:34:51 UTC
Okay, yes, I was receiving NO error messages whatsoever re the "new" apps. After reading the response I finally went in with yum and neutered kde-plasma-networkmanagement. Once I did, all 8 apps FINALLY installed and cleared from the update screen in Apper. That little portion of my life is cleaner now. Thank you.

I will vote that this item is closed (at least for me).


Note You need to log in before you can comment on or make changes to this bug.