Bug 1046279 - [RFE] [engine-webadmin] refresh view is rolled up to the list head
Summary: [RFE] [engine-webadmin] refresh view is rolled up to the list head
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Alexander Wels
QA Contact: Petr Kubica
URL:
Whiteboard:
Depends On:
Blocks: 1172380
TreeView+ depends on / blocked
 
Reported: 2013-12-24 10:26 UTC by Elad
Modified: 2016-03-09 20:34 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1172380 (view as bug list)
Environment:
Last Closed: 2016-03-09 20:34:42 UTC
oVirt Team: UX
sherold: Triaged+


Attachments (Terms of Use)
screenshot (192.91 KB, image/png)
2013-12-24 12:49 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 34211 master MERGED userportal,webadmin: preserve grid scroll Never

Description Elad 2013-12-24 10:26:26 UTC
Description of problem:
When we roll down to the bottom of a list in the UI (of VMs for example) which is longer than the screen capacity and then we refresh the view, the view will be rolled up to the head of the list instead of preserve the last location in the view before the refresh.

Version-Release number of selected component (if applicable):
is28.1
rhevm-webadmin-portal-3.3.0-0.41.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. have a VMs list which is longer than the screen capacity (so it will be possible to roll down) and roll down to the bottom of the list
2. refresh the list


Actual results:
The view is rolled up to the top of the list.

Expected results:
The view should be rolled down to the last location it was before the refresh.

Additional info: screenshot

Comment 1 Elad 2013-12-24 12:49:16 UTC
Created attachment 841246 [details]
screenshot

Comment 4 Einav Cohen 2014-05-15 15:01:45 UTC
indeed. scroll-location should be preserved across refresh-actions.

Comment 5 Petr Kubica 2015-04-20 10:14:44 UTC
Verified in 3.6.0-0.0.master.20150412172306.git55ba764.el6

Comment 8 errata-xmlrpc 2016-03-09 20:34:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.