Bug 1046426 - blank screen after upgrade libevdev
Summary: blank screen after upgrade libevdev
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libevdev
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1046453 1046461 1046756 1047023 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-25 08:34 UTC by Mikhail
Modified: 2014-02-22 12:28 UTC (History)
17 users (show)

Fixed In Version: libevdev-0.6-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-27 13:04:18 UTC


Attachments (Terms of Use)

Description Mikhail 2013-12-25 08:34:51 UTC
Description of problem:
After upgrade libevdev 0.5-1.fc20 to 0.6-1.fc20 version and reboot computer I see blank screen instead user logon.

Downgrage package to 0.5-1.fc20 version helps to solve this issue.


$ lspci
00:00.0 Host bridge: Intel Corporation 82Q35 Express DRAM Controller (rev 02)
00:01.0 PCI bridge: Intel Corporation 82Q35 Express PCI Express Root Port (rev 02)
00:03.0 Communication controller: Intel Corporation 82Q35 Express MEI Controller (rev 02)
00:19.0 Ethernet controller: Intel Corporation 82566DM-2 Gigabit Network Connection (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 02)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 02)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 4 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IO (ICH9DO) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 6570/7570/8550]
01:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Turks/Whistler HDMI Audio [Radeon HD 6000 Series]
04:00.0 IDE interface: Marvell Technology Group Ltd. 88SE6101/6102 single-port PATA133 interface (rev b2)
07:03.0 FireWire (IEEE 1394): LSI Corporation FW322/323 [TrueFire] 1394a Controller (rev 70)


$ uname -a
Linux ws166.afbank.ru 3.12.6-300.fc20.i686+PAE #1 SMP Mon Dec 23 17:02:24 UTC 2013 i686 i686 i386 GNU/Linux

Comment 1 sheepdestroyer 2013-12-25 12:43:30 UTC
I can report the same problem on my laptop (Lenovo x220, intel core i7 Sandybridge)

After updating to libevdev 0.6-1.fc20 the boot process stop displaying messages after
 systemd[1]: Starting Authorization Manager...

When logging as user on an other console then startx, get a "oops gnome has crashed" message

after reverting to libudev 0.5-1.fc20, no such problem anymore

Comment 2 Mamoru TASAKA 2013-12-25 13:10:30 UTC
$ which gnome-shell | xargs ldd -r 2>&1 | grep undefined
undefined symbol: LIBEVDEV_READ_NORMAL  (/lib/libclutter-1.0.so.0)
undefined symbol: LIBEVDEV_READ_SYNC    (/lib/libclutter-1.0.so.0)

Looks like libevdev.so.1 removed some symbols without bumping soversion.

Comment 3 Mamoru TASAKA 2013-12-25 13:11:37 UTC
Note that bumping soversion requires rebuild of all depending packages.

Comment 4 Mamoru TASAKA 2013-12-25 13:25:42 UTC
http://cgit.freedesktop.org/libevdev/commit/?id=7a38f4abc3ed1df368d5bad32a1d72559acdc234

This type of change should not be brought on stable branch.

Comment 5 domgross 2013-12-26 02:06:08 UTC
same issue here:

$ journalctl -b -1 /usr/bin/gnome-session

-- Logs begin at Wed 2013-07-24 13:58:35 CEST, end at Thu 2013-12-26 02:31:51 CET. --
Dec 26 02:02:34 pressanykey gnome-session[1320]: Entering running state
Dec 26 02:02:34 pressanykey gnome-session[1320]: gnome-shell: symbol lookup error: /lib64/libclutter-1.0.so.0: undefined symbol: LIBEVDEV_READ_NORMAL
Dec 26 02:03:44 pressanykey gnome-session[1320]: (gnome-settings-daemon:1372): Gdk-WARNING **: gnome-settings-daemon: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.



this may be relevant:

https://git.gnome.org/browse/clutter/commit/?h=clutter-1.18&id=3cd9a70fea1ccf795419a1726c7c279b0aaf237e

Comment 6 Igor Gnatenko 2013-12-26 10:09:21 UTC
confirm

Comment 7 Stefan Neufeind 2013-12-26 12:38:32 UTC
from the patch in comment #5 it looks like the new API was already there since 0.4. So if it's not already in the sources used by Fedora, we should be able to start using the new API "now" (with 0.5), maybe also in other packages, and later upgrade libevdev.

Comment 8 Flóki Pálsson 2013-12-26 18:58:35 UTC
libevdev-0.6-1.fc20.x86_64
woerks in 
Linux F20bt 3.12.6-300.fc20.x86_64 #1 SMP Mon Dec 23 16:44:31 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Comment 9 Adam Williamson 2013-12-27 03:03:53 UTC
I'm going to send a libevdev build that restores the 'deprecated' functions and possibly also a clutter build with the patch from c#5 to Rawhide. That would fix it from both ends. whot and desktop team can take another swing at implementing this change in a way that doesn't break the world, once they get back from vacation. Many thanks to Dom and Mamoru for identifying the offending changes.

Comment 10 Adam Williamson 2013-12-27 04:04:20 UTC
F20 should be OK, as the offending update has been unpushed. I'll leave it to whot and desktop team to decide what they want to do for F20.

For Rawhide, I've now sent out new builds of clutter and libevdev, fixing the problem from both ends. They seem to be working fine on my system. If you don't want to wait for mirrors, grab them from Koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=486899 (libevdev)
http://koji.fedoraproject.org/koji/buildinfo?buildID=486900 (clutter, still building, should be done soon)

either on its own ought to resolve the issue, I tested with both together.

Comment 11 Mark T. Kennedy 2013-12-29 17:34:46 UTC
does 'cheese' start successfully on your patched system, adam williamson?

Comment 12 Adam Williamson 2013-12-29 20:52:22 UTC
Just ran it, seems to work fine.

Comment 13 Peter Hutterer 2014-01-02 22:20:07 UTC
Sorry about this mess, my fault. I assumed that nothing yet requires libevdev (and anything that does would use the stable API already). 

For F20: I'll probably leave 0.6 in with the reverted changes (building as I type), we haven't seen big changes anyway so supporting the deprecated API shouldn't be too hard.

Comment 14 Fedora Update System 2014-01-02 23:04:18 UTC
libevdev-0.6-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/libevdev-0.6-3.fc19

Comment 15 Fedora Update System 2014-01-02 23:05:48 UTC
libevdev-0.6-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libevdev-0.6-3.fc20

Comment 16 Peter Hutterer 2014-01-02 23:11:37 UTC
rawhide build: http://koji.fedoraproject.org/koji/taskinfo?taskID=6350554

Comment 17 Peter Hutterer 2014-01-03 01:36:20 UTC
*** Bug 1047023 has been marked as a duplicate of this bug. ***

Comment 18 Peter Hutterer 2014-01-03 01:37:03 UTC
*** Bug 1046756 has been marked as a duplicate of this bug. ***

Comment 19 Fedora Update System 2014-01-03 14:59:16 UTC
Package libevdev-0.6-3.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libevdev-0.6-3.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-0120/libevdev-0.6-3.fc20
then log in and leave karma (feedback).

Comment 20 Josh Boyer 2014-01-06 13:46:40 UTC
*** Bug 1046461 has been marked as a duplicate of this bug. ***

Comment 21 Fedora Update System 2014-01-27 13:04:18 UTC
libevdev-0.6-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Kalev Lember 2014-02-22 11:07:00 UTC
*** Bug 1046453 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.