Bug 104655 - Up2date freezes starting to install all available Servern Beta 1 updates
Up2date freezes starting to install all available Servern Beta 1 updates
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: up2date (Show other bugs)
beta1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-18 10:48 EDT by Axel Supppantschitsch
Modified: 2005-10-31 17:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 15:40:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Axel Supppantschitsch 2003-09-18 10:48:20 EDT
Description of problem:

Up2date freezes after successful download of Red Hat Linux (Severn) 9.0.93 - 
Beta Updates. Happens with grapchical and text mode up2date clients.

Version-Release number of selected component (if applicable):

up2date-3.1.46-2
up2date-gnome-3.1.46-2
rpm-4.2.1-0.11
rpm-build-4.2.1-0.11
rpm-devel-4.2.1-0.11
rpm-python-4.2.1-0.11 

up2date-3.9.28-2
up2date-gnome-3.9.28-2
rpm-4.2.1-0.30
rpm-build-4.2.1-0.30
rpm-devel-4.2.1-0.30
rpm-python-4.2.1-0.30

How reproducible:

Steps to Reproduce:
1. Full install (all packages) Servern from CDRs (Iso)
2. Add channel Red Hat Linux (Severn) 9.0.93 - Beta Updates
3. Start up2date and select ALL updates (kernel, gdm, and all other updates)
    
Actual results:
Dependencies are resolved without problems
All updates are successfully downloaded
up2date(-nox) freezes at the begin of the installation process (tested: 1 hour 
no screen or harddisk activity, 100% cpu load)

Expected results:
Sucessful installation of all avialable Severn Beta 1 update packages

Additional info:
Comment 1 Need Real Name 2003-09-23 05:50:58 EDT
I have the same problem here as mentioned above as well as two other problems:

I did a fresh install of severn and ran up2date to install all the beta 
updates. I had made the mistake to enable GPG Sig checking for all files and 
since the beta pakages have no sig I had to click alot of times on "yes 
install anyway" (I know its my own fault :) after downloading 20% of the files 
up2date locked up! If you disable GPG Sig checking it downloads fine but if 
you enable it and you manualy give your okay to install it freezes as well.

The next problem is that up2date is selecting aspell even though the latest 
version seems to be installed already. If you don't remove this package 
up2date will complain about it and stop the entire update process. I would 
prefer it if up2date would only tell you about it and continue updateing.
Comment 2 Need Real Name 2003-09-23 10:08:12 EDT
problem still exists in:
up2date-3.9.29-2
up2date-gnome-3.9.29-2
Comment 3 Need Real Name 2003-09-29 07:28:24 EDT
I installed the Fedora beta2 yesterday and noticed it still ships with up2date-
3.9.29-2. When I run up2date from a shell I get loads of lines with "libglade-
WARNING ** Error loading image..." and up2date (subscribed to severn-beta2 
channel) again shows me that aspell 0.50.3-15 and xemacs-el 21.4.14-1 even 
though they are already installed!
Thanks for fixing this.
Comment 4 Adrian Likins 2004-08-24 15:40:55 EDT
should be resolved in current versions (4.2.x in rhel3, and
4.3.x in fc2)

Note You need to log in before you can comment on or make changes to this bug.